👋🏾 Looking to join our SuiteCRM Community Working Group? 💌 Open invitation throughout January. Check out all the details here 👈

Missing navbar and searchbar

Hi
I just installed suitecrm and I don’t see the two taskbars in the browser
account bar and search bar.
Here is what I see from the browser.

Thanks to those who can give me a solution
Vincenzo

Hi @Vincenzo.M,

Sorry for the delay in replying.

That view that you are seeing is not meant to be accessed directly. It is there to be used by classic view that uses the legacy rendering mechanism.

The SuiteCRM 8 app should be available in /public (according to the url you have in the previous screenshot)

Do you get a blank page when accessing /public?
If so, it maybe a misconfiguration in mod_rewrite, please consider having a look at the following post

Thank for your reply but this time don’t risolve at first hit.
I modified my file httpd-ssl-vhosts-user.conf in server apache Qnap in the following way :
########################
NameVirtualHost *:91

Listen 91

<VirtualHost *:91>

<Directory “/share/suitecrm/public”>
Options FollowSymLinks MultiViews
AllowOverride All
Require all granted

ServerName suitecrm
DocumentRoot “/share/suitecrm/public”
SSLEngine on
SSLCipherSuite EECDH+CHACHA20:EECDH+AES
SSLProtocol All -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
SSLCertificateFile “/etc/stunnel/stunnel.pem”

###################

unfortunately does not work.

Did not make any changes in the .htaccess files in both the /public and /public/legacy folders.
re-write is active
I have to modify also the file .htaccess
which one?

thank fro your reply

Hi @clemente.raposo

I too am having this issue. I had to do the install through the legacy folder path because I got the blank page as well.

I enabled mod_rewrite and made the changes to the vhosts file (I created another one instead of using the default). I also created a .htaccess file in the root folder (above the SuiteCRM folder) and I inserted “RewriteEngine on” but it still doesn’t work for me.

I am fairly new to Linux so I think there’s something I’m missing but I feel so close. I do get the “GraphQL query is not valid” error when I go to the api/graphql

Hi @Vincenzo.M,

Sorry for the delay in replying.

I’m not sure if it was just a problem in copying here, but it seems like DocumentRoot is within the <Directory> tag, but it should be outside.

Hi @Yod,

Welcome to the community :wave: and thanks for trying out SuiteCRM 8.

Your vhost configuration seems right. Thats probably not it.

  • What linux distro are you using?
  • What php version do you have?

There is an alternative that might make things easier. Are you familiar with docker? Among other things, docker images streamline and make the server setup easier.

The following post by @jont_titmus has a link to a github repo with a docker setup for SuiteCRM 8, which Jon prepared and had the kindness of sharing with us.

I think this may help overcome the server setup issues.

Please also consider having a look at the posts on this thread.

Hi @clemente.raposo

Thanks for the greeting and the quick reply.

I’m running Ubuntu 20.04.3 LTS and PHP 7.4.3 but I am using php-fpm (I’m not sure if that’s the issue).

I’m not familiar with docker and how it works and how to set it up,

Hi @clemente.raposo

I tried the docker route and after much research and effort given my inexperience with it, I was able to run the container and do the installation. However, when I try loading the site, I get the same blank page.

I am navigating to http://localhost/SuiteCRM/public

The screenshot will give you an idea of where I stopped. I did get the error that @zabusky encountered but I simply stopped the apache and mysql service. I haven’t done any configs to the vhost file or anything like that since I assumed that this wasn’t necessary within the docker image.

Any further guidance would be greatly appreciated.

Hi @Yod,

Glad you were able to make some progress.

Regarding the error on the screenshot just add the following option -W "false" that will not stop any warnings on system check

Pleased let me know how it goes.

Hi @clemente.raposo

I may not have been clear in my previous update.

I am saying that after the install (screenshot as per my previous post), I am getting a blank page on the localhost/SuiteCRM/public page. Based on the screenshot, I assume the installation was successful but the login page is not loading.

Hi @Yod,

ahh ok. When you get that message on the terminal it usually stops there and doesn’t go any further.

anyway, I was looking into the docker file that comes with the repo. It seems that its already pointing to SuiteCRM/public

When you access http://localhost what do you get?

When I access http://localhost I get the following the SuiteCRM folder

When I go inside of the SuiteCRM folder I get:

When I go to the public folder, the page is blank.

Maybe it’s a permissions issue? I ran the command as sudo but I’m not sure if there’s something I’m missing.

Hi @clemente.raposo

I got through with the installation but when I log in I get a 500 Internal Server error on some of the pages. The Home page, Administration and a couple others. I ran the command for the permission as stated in the install guide but I’m not sure why it is generating this error.

Hi @clemente.raposo

Just an update. I got the issue resolved by referring to another forum post.

Thanks for your help. Now I can start testing this out.

Hi @Yod,

Glad you were able to solve it! And sorry for not having replied back sooner.