Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Fresh SuiteCRM 8.0.1 install has 500 errors in subpanels

I have completed a fresh install on a VPS - nothing else on the server other than Suite CRM.

The install is on Centos 8. SE linux has been disabled for the moment. HTTPS has been set up and is working. Install is using PHP 7.4. Apache is 2.4.37. Database is on another server but the install worked and I am able to log-in with the admin user without any issue. A clean install (no demo data) is in play.

Initially the ‘dashboard’ throws a 500 error

Going through to ‘list’ pages they display, but obviously without any records to show at the moment.

But when I try and create some "New" items, I get 500 errors for some, and for others it works.

I can create new Contacts, Accounts, Opportunities for example,

but not a Quote and nor, crucially, Employees nor am I able to access the ‘Admin’ area.

Looking through the forums it seems that the permissions may be the cause but I have checked, and rerun those through again so I think they are correct and working.

I have included the network tab. Both Firefox and Chrome are behaving in the same way.

Any ideas anyone?

These are the log entries that may help:

[77081][1][FATAL] Error: File [modules/SavedSearch/metadata/editviewdefs.php] is missing. Unable to create because no corresponding HTML file was found.

No errors were reported in the PROD log file.

This error is reported in the Apache error.log

[core:alert] [pid 77388] [client nnn.nn.nnn.nn:49719] /var/www/xxx.xxxxx.co.uk/SuiteCRM/public/legacy/.htaccess: RewriteBase: argument is not a valid URL, referer: https://xxx.xxxxx.co.uk/

The RewriteBase value set in the ‘legacy’ .htaccess file was:

RewriteBase xxx.xxxxx.co.uklegacy/

This seems strange that there is no “/” after the .co.uk. I have tried various alternatives, e.g.

RewriteBase xxx.xxxxx.co.uk/legacy/
RewriteBase xxx.xxxxx.co.uk/legacy

and none of them make any difference.

What should RewriteBase be set to?

If this isn’t the problem, does anybody else have any ideas.
Thnaks

Hi @simondawson,

Glad you were able to do some progress.

As you correctly guessed the problem is most likely related with RewriteBase

In your case your value should be RewriteBase /legacy

Some more info on this here:

Just a side note:

  • the views that are having errors are the ones that are using the classic view mode. That falls back to legacy rendering.

Thanks @clemente.raposo , that has solved the problem for me. I can now configure it and get it up and running properly.

Cheers
Simon
p.s. thanks for the other information about the routing of the views - that will help me to understand the whole system.

1 Like