Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

SuiteCRM 8 Beta - Install Questions

Hi @clemente.raposo,

Yes, I removed the .env.local replacing it with the .env.local.php and left the .env untouched.
This made no difference though :frowning:

Oh, and it was installed from the pre-built package here: https://suitecrm.com/suitecrm-8-beta-preview/ Though I have a feeling it was beta 2 not beta 3… Would upgrading be any help?

Hi @jont_titmus,

Yup, thats the correct link.

Beta 3 has some new features and fixes. But they aren’t related with this, from what I’m aware of.

Could you try adding the following error_log next to the other ones please?

error_log($_SERVER['APP_ENV'])

Found some StackOverflow threads with what seems to be a similar issue:

@clemente.raposo OK, I’ve cracked it :smiley:

For what ever reason, the .env.local file is being entirely ignored in favour of an expected, (but not present), docker .env file. So, I’ve created a .env file within the container config and added the $DATABASE_URL argument which has done the trick :slight_smile:

I need to do some tidying up, but once done Ill post a link to the repo for anyone interested.

1 Like

Hi @jont_titmus,

Great! very glad to hear!

If you could post that info it could be a huge help. Thank you

@clemente.raposo -> https://github.com/jontitmus-code/SuiteCRM8_docker
Let me know what you think :smiley:

3 Likes

Hi @jont_titmus, had a quick look, looks nice. Like the way its structured. Thanks for sharing!

1 Like

Hey there,

I am struggling to install the Beta 3… :slightly_frowning_face:

Currently on macOS using MAMP Pro, all my versions seem to be compatible with the Beta thanks to the compatibility matrix.

I tried to install the Beta using the .zip available in the Downloading & Installing Guide.
Also tried to install it via the Github repo, following the Developer Install Guide.

Here is what my Terminal says each time I enter my database’s creditentials :

Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Failed
Step 2: Legacy Installation Complete

It seems to be a permission issue regarding the install.log file situated in public/legacy/ :

2021-09-13 09:19:46...ERROR: Cannot create writable dir cache/upload/import
2021-09-13 09:19:46...installerHook: Info: custom/install/install_hooks.php not present, no custom hooks to execute

I really don’t know what else could it be, but also don’t know what other permissions could I set instead of [myusername]:staff as it is the ones set on the root folder and into MAMP Pro ?

Thank you for your time, we can wait to start using SuiteCRM 8 ! :oyster:

Hi @maxonss,

Thanks for trying out SuiteCRM 8 beta.

Have you already tried using the zip on the following page? SuiteCRM 8 Beta - SuiteCRM. (This one is the “pre-built” package)

image

The install steps for the above zip are the ones on:

Hope this helps

Hi again,

Thank you very much for your fast answer.

Yes, I tried both methods, locally and to a distant server, I really can’t see what I’m missing… I followed exactly what the documentation says

  • Unzip the SuiteCRM Beta 3 folder into the root directory
  • Set the permissions (tried mutiple [user:group])
  • Run ./bin/console suitecrm:app:install
    (From this step, the console says that SuiteCRM Cli install failed but the legacy’s succeded)

After having set the permissions again, I set my root folder to public/ and nothing is showing now.

Same thing when installing from the repo…

I’m checking the logs trying to see something new…
Thank you again

Hi @maxonss,

Thanks for the feedback.

From first glance it seems that suite is not able to write to those folders.

Are there any logs on public/legacy/suitecrm.log that seem relevant?

One thing to have in mind is that the Beta 3 zip (unlike the Beta 2) has an inner folder inside the zip, where the beta 2 had the project files directly on the root level of the zip.

How does your structure look like from the root? is SuiteCRM 8 (core, cache, etc) directly on the root folder?

Hello @clemente.raposo !

Thank you again,

Are there any logs on public/legacy/suitecrm.log that seem relevant?

The only thing that I can see is in suitecrm.log is this :

Tue Sep 14 12:05:48 2021 [56724][-none-][FATAL] Could not connect to DB server http as root. port //localhost/: 

Here is what my folder looks like as Suite/ is part of the root directory of my virtual host (Suite/public/) :

Do you think the failure comes from permissions ?

Hi @maxonss,

From the log message seems a different thing. Suite is not able to reach the db.

Could you try using 127.0.0.1 instead of localhost (or whatever the host is), please? Sometimes localhost is assumed as the socket connection.

Maybe also worth checking if there is any other db setup config that maybe missing

1 Like

Hello @clemente.raposo,

I tried to set 127.0.0.1 as the database host name and the only thing that changed is that I can see a Symfony debugger bar at the bottom of the project now :

Errors still the same :

Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Failed
Step 2: Legacy Installation Complete
Thu Sep 16 08:28:35 2021 [65586][-none-][FATAL] Could not connect to DB server localhost as root. port 3306: No such file or directory

Database still not created…

It looks like I’m not using the correct mysql as I’m running SuiteCRM via Mamp Pro.

Installation script ./bin/console suitecrm:app:install may be using the mysql installed by hand via the command line and not the one used by Mamp Pro ?
I’m currently looking for a way to find out which one is used (mysql).

Thank you very much for your help, I hope to find out what I’m missing

Hi @maxonss,

I don’t have much experience with MAMP pro, though maybe the these threads may help:

Not sure if there is any security risk in disabling the options they talk about.

Hope this helps

Hey @clemente.raposo,

Thank you for the resources you gave me, it helped a bit.

Just succeed the install using the “pre-built” package, I don’t know WHY it now works, but I think it could be because I deleted the mysql I installed using brew before, still using 127.0.0.1 instead of localhost.

Here’s the history of the CLI install :

SuiteCRM Silent Install
============

Please enter the db username: root
Please enter the db password:
Please enter the db host: 127.0.0.1
Please enter the db name: suite8
Please enter the admin username: max
Please enter the admin password: ***
Please enter the suite 8 address: http://dev.suite8/
Install demo data:
  [0] yes
  [1] no
 > 1

Step 1: Config Creation Complete
Starting SuiteCRM CLi Installation
SuiteCRM CLi Install Complete
Step 2: Legacy Installation Complete

I will update this post when I’ll figure out how I succeed in the install, hoping it’ll help some people in the same situation.

Hi @maxonss,

Great! Very glad to know that you were able to install.

And yes, it would help a lot if you could share the root cause of the problem.

Thanks

Just figured out that it may have worked because I changed localhost to 127.0.0.1 (or whatever associated IP address) following @clemente.raposo’s advice.

Many thanks,

Hello again,

I am really sorry I have to ask for help again… I can’t find the issue nowhere and it seems to be about permissions, for real this time :

Symfony debugger tells me that it’s Unable to write in the “cache” directory :

Also tells me sometimes that it cannot open a file in append mode.

Here are the permissions set into the cache/ folder (server running Ubuntu) :

root@hungry-darwin:/var/www/vhosts/[domain_name]/httpdocs# ls -al cache/
total 12
drwxrwsr-x  3 www-data www-data 4096 Sep 21 11:25 .
drwxrwsr-x 13 www-data www-data 4096 Sep 21 11:49 ..
drwxrwsr-x  2 www-data www-data 4096 Sep 21 13:59 dev

I set the permissions again, just after launching the install ./bin/console suitecrm:app:install

I also tried to create the folder it was asking for by hand but nothing helped.


Symfony debugger also told that mkdir(); couldn’t be executed so it reinforces the idea that it’s surely a permission issue.

Thank you everyone for your time

Hi @maxonss,

How is your system setup? Are you using docker, vagrant or plain VM? Or is it just a regular ubuntu server?