🚀 DaVueTheme 1.0.1-beta release. Reactive theme for SuiteCRM is now available to download!

Previous posts

Reactive theme for SuiteCRM 7.x, is a simple downloadable module and is compatible with the standard out of the box design.

  • Client-Driven Design Improvements: Incorporates design enhancements based on a decade of client feedback and wishes.
  • VueJS 3 Engine: Utilizes the latest VueJS 3 engine for enhanced interactivity and responsiveness.
  • Backward Compatibility: Fully compatible with SuiteCRM 7.11.6++, ensuring smooth integration with existing systems.
  • Easy Installation: Simple .zip distribution, easily installable through Module Loader, allowing for hassle-free setup.
  • Link Compatibility: Maintains compatibility with all existing links, ensuring seamless transition between old and new interfaces.
  • Parallel Use with Standard Design: Offers the flexibility to use DaVueTheme alongside the standard SuiteCRM design.
  • User-Friendly Interface: Focus on improved usability and a more intuitive user experience.

and much more…

Here’s a quick video demo:

Currently fully compatible with:

  • SuiteCRM 7.11.6 - 7.14.3
  • PHP 7.3 - 8.2

More details: README

The demo instance is up and running:

Demo: demo.doappweb.com
Login: vue
Password: 12345

Downloading and Installation steps

Download: release page

Download the zip file which starts with daVueTheme_v (example: daVueTheme_v1.0.0-beta.zip)


  • Log into SuiteCRM (requires “System Administrator User” user type)
  • Admin > Module Loader (to access the Module Loader)
  • Upload the zip file
  • Follow the simple on-screen instructions

if you encounter difficulites please consult the video above for a quick step-by-step demo

Usage Rights:

  • All versions of DaVueTheme will be available for free!


  • Further refine the functionality and backward compatibility
  • Add the ability to granularly configure the ‘frontend’ both through code and settings
  • Add a new Studio and Module Builder
  • Start working on compatibility with SuiteCRM 8 (as soon we finalize working on v7.14.x)


  • Feel free to use this forum or the contact form on doappweb.com

Looking forward to your questions and feedback!
Best regards, DoApp team!

P.S. Could you take a moment to please the link to this thread in other forum sections. This will allow us to gather more feedback and enhance DaVuetheme even further!


First install gave me php errors with the controller and Chmod errors. - granted this was on a replica of a production instance so that could be something i’ve done making it squiffy.

Second install on a fresh instance after module loader loads it in and as soon as it goes to default it gives me error 500 and then in incognito mode it returns 403 not found pages

[core:crit] (13)Permission denied: AH00529: /var/www/vhosts/test-realm.mgweb.co.uk/httpdocs/app/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/var/www/vhosts/test-realm.mgweb.co.uk/httpdocs/app/’ is executable, referer: https://test-realm.mgweb.co.uk/index.php?module=Users&action=DetailView&record=1

third install - get the core crit error still and

can confirm i’m within your matrix 7.13.4 and php v7.3 and 8 (tried both)

This is alll looking like permission based issues which I’ll look at - I just went firstly with the gung-ho lets get it thrown into module loader and see what’s what attitude :smiley:

chmod +x /var/www/vhosts/test-realm.mgweb.co.uk/httpdocs/app
chmod -R 755 .
chmod -R 775 cache custom modules themes data upload config_override.php

did it for me :slight_smile:

Thanks for the report!
I.e. the problem was in the rights to the files, and not on the DaVueTheme side?
In theory, if the rights had been assigned before installing the theme, then there would not have been any problems with the installation, as we see it.
Or, we can assume that on your instance, for some reason, the module loader works with different permissions than the web server…

In any case, it was a good test case and we, for our part, will check it again! Thanks!

I traced it back to the config.php applying file permissions while it was doing it’s thing - reverting to a backup before install and correcting the default perms array within config.php - the application did load as expected, no intervention required.

1 Like

Release has been updated to version 1.0.1-beta!

Added compatibility with SuiteCRM 7.14.x and PHP 8.2


Do you have demo links for those versions? :sweat_smile:

I’ve just put these onto test instances i’ve got for both variants.

However - major drawback - there’s no reporting… And the reports already in situ get ruined the instant i install - not sure if i’m the problem or if it is the problem. Usually 99.9% it’s me that’s the problem lol

Hello everyone,
I installed the latest version and as soon as I activate the theme I have a 404 error. I changed the permissions and still the same problem have you an idea?

In the demo, the specified headline message, (demo.doappweb.com ) the exact same package that is offered for download is installed.
We currently keep SuiteCRM 7.13.3 and PHP 7.4 as a base - this makes it easier to track backward compatibility.

The Reports module (as well as the Email and Process Manager modules) is one of the few that, due to their specifics, are not fully ready. That is why there is a “beta” in the release title.
Just this week, we completed the integration of a new library for displaying graphs - Apache ECharts and started working on management and report display interfaces.
Unfortunately, due to limited resources, we have to choose what to do first, and not all at once.

1 Like

Thanks for the report!
If it is not difficult, please provide the following parameters:

  • web server,
  • PHP version,
  • SuiteCRM version,
  • browser,
  • query string that returns 404

Judging by the description, you have a problem with redirecting to the “app” folder, which contains the entire frontend.
Check it out, it should look something like this: <hostname>/app/?.
You can try manually changing it in the browser to https://<your_host_name>/app/?module=Home&action=index
We also recommend checking the correctness of filling in ‘host_name’ and ‘site_url’ in sugar_config of your instance


  • Ubuntu 22.04.3
  • Php 8.1.27
  • Suitecrm 7.14.1
  • Browser : Chrome, Firefox and Safari
  • query sting ? how find this ?

When i use the theme the browser has this adress : /suitecrm//app/?module=Users&action=DetailView&record=4c6c1217-2b26-6390-02ec-5dd430be6233
When i use" /suitecrm/app/?module=Home&action=index" error 404 too

I don’t found Sugar_config who is the file ?
Many thanks

Hi, @quicktin !
Thanks for the answers, let’s try to figure them out…

You have specified Ubuntu.
Apparently you meant that your web server is installed on it.
Considering that this is Ubuntu, it means it can be either Apache or Nginx + FPM
Please clarify…

Php, Suitecrm, Chrome, Firefox and Safari - everything is ok

Next, I was interested in what you have in the browser address bar, after the host (query string)
Here you have given something interesting (if it is not a typo):


Double slash before app/? - this should not happen.
If this is not a typo, then this is the reason for the 404 error.

The source of the double slash may be incorrect values in the same $sugar_config.
The $sugar_config itself is not a file, but a global array of SuiteCRM configuration generated in files:

  • config.php
  • config_override.php

You need to check them (both, because one overlaps the other), looking for values for host_name and site_url.
The correct values should look like this:

At the installation for example.com :

  • 'host_name' => 'example.com'
  • 'site_url' => 'http://example.com'

Or, for example, how it looks like in our demo:

  • 'host_name' => 'demo.doappweb.com'
  • 'site_url' => 'https://demo.doappweb.com'

Please note - these values are without slashes

1 Like

Hi,have a nice day Hope your doing well actually first of all this is very amazing,I wanted to try to test this plugin by following steps in youtube video but in my suitecrm it didnt work,I checked in source code also module of plugin successfully created,but in themes page when choose Davue theme and click save,logout relogin but didnt change also I made repair in case but didnt work,then I tested smth like this I went to user management,user profile there is themes tab also there Davue theme successfully added when I choose that theme and click save suitecrm crashed
after theme chose as Davue error image in user profile settings:

Greetings and thanks for the report.

I see the apache server, is already good =)
Judging by the screenshot, for some reason
the .htaccess lying in the app/ folder did not work (check its availability by the way)

Possible reasons:

  • mod_rewrite for Apache is not enabled
  • somewhere at the server or virtual host level, you have prohibited/disabled additional .htaccess

By itself, .htaccess just proxies requests to the dist folder for frontend-application

P.S. Also, I recommend checking the settings of $sugar_config, (see the message above), because judging by the screenshot, you have an unusual host and url

Thanks for reply and explanation just I got confused could u give me explanation step by step what should I do or what should I check I would be thankfull to you.


You have presented an interesting case…
We discussed it with the team and decided to try to make an update for DaVueTheme, which will get rid of the Apache mode_rewrite and .htaccess dependencies

Will you be able to test it on your instance if I send the test distribution to you personally?

Yes of course I would be happy

I sent the link in a personal message