Unable to log in after fresh instalation

I’ve tried this several times using cPanel and the Softaculous Apps installer.

After creating the new install, I’m not able to log in with the credentials provided.

Username admin

Any help appreciated

Some install failure ideas…

  • try to login to the install page http://mydomain.com/#/install
  • try to login to the app http://mydomain.com
  • do you know if http vs/or https setup?
  • use the IP address instead of mydomain.com
  • is mod rewrite enabled
  • did you setup a suitecrm.conf file in apache/sites-available ; if so where does the folder point to?

Some installed fine but not working ideas…

  • which admin password are you using, your application password or db user password?
  • I think the main web page should come up even if your back end DB (MariaDB, MySQL, etc) is not online, granted, it will soon crash on the next page when a DB request is made
  • does the cPanel/Softie install ask you to define an app username and password?
  • which version of SuiteCRM is being installed, I believe there are different rights on v7 vs v8 (/var/www/html/suitecrm with www-data if using Ubuntu)

It’s normal for a lot of people in forums to complain that you are asking for help with little specifics. Your problem could be anywhere.

Can you install VirtualBox on your PC/Mac/Linux and walk through an test/temp install there? I’ve found that very helpful for rolling out projects. Just keep taking snapshots so you don’t have to repeat work.

Sadly, none of those recommendations helped.

I can get to a login screen but nothing I do will allow me to log in with the credentials provided.

It’s like the app is working but the credentials are wrong. I can access the database, and I can see the root user is admin but I have no way of changing the password as I don’t know the encryption used.

You can access your DB and perform the below steps

1 Like

So I use this query in PHPMyadmin:

UPDATE users SET user_hash = MD5(‘admin’) WHERE user_name = ‘admin’;

I’ve used with single quote and double quote around the username, and always get the following error:
#1054 - Unknown column ‘‘admin’’ in ‘where clause’

I’ve tried with and without backtics around table names as well, but still no luck. Always the same error.

Any help appreciated

Check these topics and maybe for version 8, you have different table or column name for users.