SuiteCRM Upgrade Process from 7.13.x to 8.4


I am trying to upgrade from 7.13.x to 8.4. Can somebody explain what is the correct procedure please, as I have looked at the docs already but they seem to contradict each other.

On the following page it says you can upgrade from 7.12.x to 8.x:

On the download page below the only migration package is from 7.14.x to 8.x

When I try to upgrade from 7.13.x (my current version) to 7.14.x, the upgrade screen goes blank half way through the upgrade process, something I have been unable to resolve. The server meets all the requirements and I have reset permissions and ownership multiple times.

What is currently the best way for me to get onto 8.4 from 7.13.x please? Is it via 7.14.x (in which case I will create a new post about my blank upgrade screen issues) or can I go straight to 8.4 (and if so how and where is the migration package)?

Thanks a lot


1 Like

has anybody managed to upgrade to version 8 or is everybody starting from scratch with a clean install?

I’ve attempted it about 3 or 4 times, it’s nigh on impossible. I think I got as far as being able to see the new login screen once. I’ve now given up and will stay on the 7.x.x version for as long as I can.



If someone create how to upgrade video and upload it. It will be helpful for everyone who is facing an issue.

If they have it already on official channel, please share link here.

I just wanted to post back on here as I managed to upgrade from 7.13.x to 7.14.1 finally. I saw another forum thread (sorry can’t remember which one) suggesting running the update with PHP 7.4 as the problem I encountered is only an issue with PHP 8+. I rolled back to PH 7.4 and the update ran perfectly first time using the 7.14.1 Upgrade from 7.13.x dated 3rd October. I then moved back to PHP 8.0 once it was done.

I’m going to hold off on going to v8 for now, but at least 7.14.1 is a step forward.

Hope this helps somebody else.


@Andyg , thank you for your post. It will help lot of us while doing upgradation.

1 Like

No problem. Just a point to note, the PHP requirements are 8.1 or 8.2 for SuiteCRM 7.14.1 so worth upgrading to that rather than staying on PHP 8.0.

I’ve tried endless times without success. I think there is something strange going on with the upgrade scripts .

./bin/console suitecrm:app:setup-legacy-migration prompts you to set the correct rewriteBase in the public/legacy.htaccess.

eg. /crm/public/legacy

When the script completes, the .htaccess file appears to have been deleted.

After running ./bin/console suitecrm:app:setup-legacy-migration the .htaccess is still missing.

After running ./bin/console suitecrm:app:upgrade-finalize the .htaccess is back again,

but now the rewriteBase is set to /crm/legacy.

I’ve tried so many paths for rewriteBase it’s unreal. Nothing seems to work. All i see is an empty menu bar with a search box, and the animated logo pops up and disappears.


Check this out!

thanks @rsp

that was really helpful, i started from scratch and appear to have it working, though had to delete the legacy custom file to get anything to show, reinstated it and all is good.

aside from missing the top menu - perhaps this has something to do with some custome code maybe so will keep chipping away

1 Like

I couldn’t figure out which part of my original instance might have been causing issues.

In the end i decided to download a new install of 8.4.1, and ran winmerge to identify the differences betwen my old code and the new instance.

Picking my way though it, i added each difference/module at a time and ran the quick repair to create new database fields etc. Once that was finished i changed the db settings in config.php to point to my old database, and finally! it worked!

there were some very minor issues in the custom files that completely broke the display of the upgrade before, and there was nothing in the logs to indicate what the problem was.

If anyone else is struggling, maybe this strategy would work. It also had the benefit of identifying redundant cold or code that was no longer needed, which didnt need to be copied over.

thanks for everyone’s help in getting it solved :smiley: