👋🏾 Looking to join our SuiteCRM Community Working Group? 💌 Open invitation throughout January. Check out all the details here 👈

Installation on Fedora 35

The login screen appears only once after installation. The application launches with no menu bar and no logout

Morning @zabusky !

Do you have a screenshot of the issue?
What does your PHP error logs say?
What does your SuiteCRM.log say?

Did you have any issues when installing itself?

The PHP error log:
[05-Jan-2022 06:26:05] NOTICE: fpm is running, pid 1348
[05-Jan-2022 06:26:05] NOTICE: ready to handle connections
[05-Jan-2022 06:26:05] NOTICE: systemd monitor interval set to 10000ms
[05-Jan-2022 07:11:36] NOTICE: Terminating …
[05-Jan-2022 07:11:36] NOTICE: exiting, bye-bye!
[05-Jan-2022 07:12:16] NOTICE: fpm is running, pid 1337
[05-Jan-2022 07:12:16] NOTICE: ready to handle connections
[05-Jan-2022 07:12:16] NOTICE: systemd monitor interval set to 10000ms
[05-Jan-2022 09:59:03] NOTICE: Terminating …
[05-Jan-2022 09:59:03] NOTICE: exiting, bye-bye!
[05-Jan-2022 09:59:40] NOTICE: fpm is running, pid 1340
[05-Jan-2022 09:59:40] NOTICE: ready to handle connections
[05-Jan-2022 09:59:40] NOTICE: systemd monitor interval set to 10000ms

Hey @zabusky

That looks like you are access the legacy section of the application instead of the application re-directing you to the full rendering. We’ve seen this with other users which usually is caused by not having mod-rewrite module on at server/host level. Check out this post and let us know how you get on.

mod_rewrite is enabled but the result is still the same. I was able by moving from https://localhost/suitecrm8/public/legacy/index.php?module=Home&action=index to http://localhost/suitecrm8/public/legacy/index.php?module=Home&action=index I manged to get back the login screen (image attached), however after login the result is still the same

Hi @zabusky,

Thanks for trying out SuiteCRM 8.

The ... /legacy ... is there just for backwards compatibility reasons to be used on the classic views within SuiteCRM 8 views. It should not be accessed directly.

When you go to http://localhost/suitecrm8/public what do you get? A white screen?

You are correct when I enter in Firefox: https://localhost/suitecrm8/public/index.php I get a blank screen. When I enter http://localhost/suitecrm8/public/index.php I get error 404: The requested URL was not found on this server.

Kind regards
Harvey

Hi @zabusky,

Thank you.

As @samus-aran mentioned the 404 is usually due to a misconfiguration in the mod_rewrite.

Some questions to try and understand the problem.

  1. How is your setup?

    • Are you using linux?
    • are you using apache?
    • What php version do you use?
  2. Did you configure the vhost to allow overrides?

Note: There have been some users that have reported issues when using php 8. Using php 7.4 could be a good idea also.

Dear Clemente
Below is my reply

Hi @zabusky,

Thank you for the feedback.

I think the problem is on the vhost file. Could you try the following please?

Replace:
var/www/html/suitecrm8/public/legacy

with:
var/www/html/suitecrm8/public

Thanks for the prompt reply
I have already tries it before and went ahead again to amend the vhost to:
#
<VirtualHost *:80>
DocumentRoot /var/www/html/suitecrm8/public
<Directory /var/www/html/suitecrm8/public>
AllowOverride All
Order Allow,Deny
Allow from All


and of course restarted httpd. The result is still the same. It really puzzles me why the application does not fully launch with the menu bar and the possibility to logout. I also tried to change the vhost to listen on port 90 but the result is still the same
Kind regards
Harvey

Hi @zabusky

Ok, thank you.

Are you using php-fpm / fastcgi?

Hi Clemente

When I run in the browser: phpinfo.php I note that all php-fpm is active. Below are all fastcgi directives:
Directive, Local Value, Master Value
cgi.discard_path: Off,Off
cgi.fix_pathinfo: On, On
cgi.force_redirect: On, On
|cgi.nph: Off, Off
cgi.redirect_status_env: no value, no value
cgi.rfc2616_headers: Off, Off
fastcgi.error_header: no value, no value
fastcgi.logging: On, On
fpm.config: no value.no value

On another note, I do apologise for some delay in my response. I am a 71 years old Australian and your message was received at 23:08 my time.

Kind regards
Harvey

Hi Clemente

When I run in the browser: phpinfo.php I note that all php-fpm is active. Below are all fastcgi directives:
Directive, Local Value, Master Value
cgi.discard_path: Off,Off
cgi.fix_pathinfo: On, On
cgi.force_redirect: On, On
|cgi.nph: Off, Off
cgi.redirect_status_env: no value, no value
cgi.rfc2616_headers: Off, Off
fastcgi.error_header: no value, no value
fastcgi.logging: On, On
fpm.config: no value.no value

On another note, I do apologise for some delay in my response. I am a 71 years old Australian and your message was received at 23:08 my time.

Kind regards
Harvey

Hi @zabusky,

Not a problem : )

From the logs you’ve posted before I should have understood your were using fpm:

[05-Jan-2022 06:26:05] NOTICE: fpm is running, pid 1348
[05-Jan-2022 06:26:05] NOTICE: ready to handle connections
[05-Jan-2022 06:26:05] NOTICE: systemd monitor interval set to 10000ms

FPM/fastcgi requires a slightly different setup according to symfony’s documentation.

If you are using Apache 2.4

If you are using apache 2.2

I think the above may be what we need.

Please let me know if you still have issues.

Its a bit late over here and going into the weekend, I may only reply on Monday.

Hi Clemente
Below is the vhost per recommendation in symphony for Apache/2.4.52. The problem still persist.
#
<VirtualHost *:80>
ServerName suitecrm8.local
ServerAlias ServerAlias www.suitecrm8.local

# Uncomment the following line to force Apache to pass the Authorization
# header to PHP: required for "basic_auth" under PHP-FPM and FastCGI
#
SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1

# For Apache 2.4.9 or higher
# Using SetHandler avoids issues with using ProxyPassMatch in combination
# with mod_rewrite or mod_autoindex
<FilesMatch \.php$>
    # SetHandler proxy:fcgi://127.0.0.1:9000
    # for Unix sockets, Apache 2.4.10 or higher
    SetHandler proxy:unix://usr/sbin/php-fpm|fcgi://dummy
   </FilesMatch>

# If you use Apache version below 2.4.9 you must consider update or use this instead
# ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/project/public/$1

# If you run your Symfony application on a subpath of your document root, the
# regular expression must be changed accordingly:
# ProxyPassMatch ^/path-to-app/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/project/public/$1

DocumentRoot /var/www/html/suitecrm8/public
<Directory /var/www/html/suitecrm8/public>
    # enable the .htaccess rewrites
    AllowOverride All
    Require all granted
</Directory>

# uncomment the following lines if you install assets as symlinks

or run into problems when compiling LESS/Sass/CoffeeScript assets

# <Directory /var/www/project>
#     Options FollowSymlinks
# </Directory>

# ErrorLog /var/log/apache2/project_error.log
ErrorLog /var/log/suitecrm/suitecrm_error.log
# CustomLog /var/log/apache2/project_access.log combined
CustomLog /var/log/suitecrm/suitecrm_error.log combined

Could you please tell me what are the required adjustments for the above vhost settings.
Kind regards
Harvey

Hi @zabusky,

Sorry for the delay in replying.

The configurations that you’ve sent seem ok. I’m probably missing something.

Maybe we could try a different approach. Are you familiar with using docker? Among other things, docker images streamline and make the server setup easier.

The following post by @jont_titmus has a link to a github repo with a docker setup for SuiteCRM 8, which Jon prepared and had the kindness of sharing with us.

I think this may help overcome the server setup issues.

Hope this helps, and again apologies for the delay

Hi Clemente

Unfortunately also the docker installation was unsuccessful. Below are the final part of the installation process:

Creating suitecrm_mysql_crm_1 … error

ERROR: for suitecrm_mysql_crm_1 Cannot start service mysql_crm: driver failed programming external connectivity on endpoint suitecrm_mysql_crm_1 (a1b06a29a82490565c0fac0d5d5a2e90cedeceb2608c1176281bdd204e20159c): Error starting userland prCreating suitecrm_suitecrm_1 … error
WARNING: Host is already in use by another container

ERROR: for suitecrm_suitecrm_1 Cannot start service suitecrm: driver failed programming external connectivity on endpoint suitecrm_suitecrm_1 (8b9d2740ceea06f8241d92d026de8635e1e98ced85c1129d8fbc504e2db78dcd): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use

ERROR: for mysql_crm Cannot start service mysql_crm: driver failed programming external connectivity on endpoint suitecrm_mysql_crm_1 (a1b06a29a82490565c0fac0d5d5a2e90cedeceb2608c1176281bdd204e20159c): Error starting userland proxy: listen tcp4 0.0.0.0:3306: bind: address already in use

ERROR: for suitecrm Cannot start service suitecrm: driver failed programming external connectivity on endpoint suitecrm_suitecrm_1 (8b9d2740ceea06f8241d92d026de8635e1e98ced85c1129d8fbc504e2db78dcd): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use
ERROR: Encountered errors while bringing up the project.
Regards

Harvey

Hi @zabusky,

I think those errors are caused because those ports are already being used by your host apache and mysql (or mariadb).

What you can try is to change the ports in docker-compose.yml to another port. Something like:

  suitecrm:
    ...
    ports:
      - "8080:80"

....

  mysql_crm:
    image: mysql
    ports:
      - "43306:3306"

The above means that you would have to access suitecrm and the db ports defined above instead of the regular ones.

ex: https://localhost:8080

Please note that the port is only for usage from the host to docker. Between docker services you can use the default ones.

So you would use the following db configurations when setting up suitecrm:

  • dbhost: mysql_crm
  • dbport: 3306 (or just leave blank)

If you are able to successfully setup and use SuiteCRM with the above you could try to disable your host apache and mysql ( if they are not being used for anything else) and they set the ports on docker-compose.yml back to the default

Hope this helps

Hi Clemente

I believe that I was able to trace the failure to launch SuiteCRM 8 on my Fedora 35 desktop to missing java scrips in the directory /var/www/html/SuiteCRM/public/legacy/cache/include/javascript. Could you please zip the content of that javascrips directory in a working SuiteCRM 8 desktop on Ubuntu or any other desktop where it works for you and email me that zip file.

Kind regards
Harvey