👩‍💻 Check out our latest job positions here 👈 or send us a PM for more info.

Index.php in public folder showing blank

Hi, after instsallation of v8, I can get access to /public/legacy/index.php, which shows the dashboards, but have no access to /public/indux.php. Shows a blank page…

Hi @Guyvdb,

Welcome to the community! :wave: and thanks for trying out SuiteCRM 8.

We’ve seen this error happening when there is some misconfiguration in mod_rewrite.

Could you double check if you have mod_rewrite active?

Also please check if your vhost configuration is set to allow overrides. Adding an example next:

<VirtualHost *:80>
    ServerName domain.tld
    ServerAlias www.domain.tld

    DocumentRoot /var/www/project/public
    <Directory /var/www/project/public>
        AllowOverride All
        Order Allow,Deny
        Allow from All
    </Directory>

I think the issue you are having is the same as the following, you could find more information here:

Hope this helps

Owkay…
I am quite comfortable with computers, but IIS is not part of the comfort zone.
I see no rules in the URL rewrite menu. Should there be one, and what should be added?
As for the vhost configuration: where to set this.
Sorry for being so ignorant.
Guy

Hi @Guyvdb,

Thanks for the feedback.

Ahh, the above options are for apache webserver.

Are you able to use LAMP stack? Even if on a VM or docker? the setup is usually easier.

If you don’t have that options I think the following posts from other community members may help the setup with IIS:

Thanks to @ljwilson and @milanraval

However please note that there maybe some significant performance issues with IIS, see:

1 Like