Fresh install, server error


I’ve got a brand new installation of SuiteCRM 8 on a fresh Ubuntu 20.04.3 server. I’m getting a server error on some pages and not on others. The Home, Calendar, Email, Profile, and Admin pages don’t display, nor any pages to import records. I can view and add records, however. After logging out, I can’t log back in (“session expired” or “unexpected error when calling action”). Instead I have to restart the server. I’m sure I’ve mad some basic mistake. Can anyone point me in the right direction?

I’m evaluating SuiteCRM 8 for our nonprofit and possibly for introducing it to other arts organisations in our area.

Hi @caravelleproject ,

Thank you for trying out SuiteCRM 8.

That error is usually related with a misconfiguration of RewriteBase in the legacy .htaccess. At the moment there is a bug in the generation of that value.

Does your vhost configuration point directly to <suite8-path>/public? If so it may be just a matter of changing the RewriteBase in public/legacy/.htaccess to /public.

Please have a look at the following post for more info:

Hope this helps

Thank you, that seems to have worked. I updated public/legacy/.htaccess so it reads RewriteBase /public/legacy and public/legacy/config.php site_url => '' (since I’m running on a virtual machine serving locally. I’m in and playing around now!

[edit] And I’m sorry, I should have figured that out myself. I didn’t read that post carefully enough at first.[/edit]

I don’t understand how in config.php would work. Or do you have it installed in your web root for But if you have it in your web root, shouldn’t the site_url read ?

I’m trying to get 8.3.1 working in a subfolder (Apache alias), so my URL is, and my Rewritebase is /public/legacy/

It works, but as so many others have reported, I run into the api/graphql 403 error (“Invalid CSRF token”).

How this can be an issue at version 8.3.1 of anything is beyond me.