After install cant repair from admin quick repair and rebuid

I try to repair from admin section on suitecrm 8.5
And getting this error?

“Unexpected error when calling action”
Then automatically main dashboar/homepage come.

What i have to check? Which log file give you idea about this error.

So far permission are given according to documentation.
And Edit config.php file following youtube video.

Config.php edited code

array (
‘dir_mode’ => 02755,
‘file_mode’ => 0644,
‘user’ => ‘cpanelaccountname’,
‘group’ => ‘cpanelaccountname’,

Could you please able give any solution, what cause this problem?

Did you use the below commands to set permissions?

find . -type d -not -perm 2755 -exec chmod 2755 {} \;
find . -type f -not -perm 0644 -exec chmod 0644 {} \;
find . ! -user www-data -exec chown www-data:www-data {} \;
chmod +x bin/console

yes i used those command but instead of www-data i use cpanel username which is owner of files and folder.

Check the below discussion.

nothing found for this issue

I would try changing Symfony to dev environment and then you get more details in the error.

You can check generic Symfony docs for how to do this

could you please reply this for normal people.haha
sorry i am not developer. :slight_smile:

At the root of your SuiteCRM folder, you find a file called .env

Inside that text file there is a line saying


which you can change (temporarily) to


Then run a cache clear:

bin/console cache:clear

Make sure you didn’t mess up the ownerships on the cache directory (this would happen if you ran those commands as root, which is not the best thing to do)

Now when you get the error again, you might get extended error information in the new debug toolbar that appears on the bottom of the screen, or in the browser’s developer tools, network tab

am i need to type this command from terminal?
and location need to be in where suite file are.
if i dont change .env file and type this bin/console cache:clear in terminal where suitecrm files are its executed.
if i change env file to dev its give me this error in terminal:

bin/console cache:clear
Symfony\Component\ErrorHandler\Error\ClassNotFoundError^ {#38
  #message: """
    Attempted to load class "DoctrineFixturesBundle" from namespace "Doctrine\Bundle\FixturesBundle".\n
    Did you forget a "use" statement for another namespace?
  #code: 0
  #file: "./core/backend/Kernel.php"
  #line: 84
  trace: {
    ./core/backend/Kernel.php:84 {
      App\Kernel->registerBundles(): iterable^
      › if ($envs[$this->environment] ?? $envs['all'] ?? false) {
      ›     yield new $class();
      › }
    ./vendor/symfony/http-kernel/Kernel.php:379 { …}
    ./vendor/symfony/http-kernel/Kernel.php:779 { …}
    ./vendor/symfony/http-kernel/Kernel.php:121 { …}
    ./vendor/symfony/framework-bundle/Console/Application.php:168 { …}
    ./vendor/symfony/framework-bundle/Console/Application.php:74 { …}
    ./vendor/symfony/console/Application.php:166 { …}
    ./bin/console:42 { …}

then after going to suitecrm url i am getting this error, cannt even login:

Attempted to load class "DoctrineFixturesBundle" from namespace "Doctrine\Bundle\FixturesBundle".
Did you forget a "use" statement for another namespace?

in suitecrm url got this error

I have seen this error a long time ago and I don’t remember how I fixed it. Maybe it’s just a matter of updating composer.

But I don’t want to send you further down the rabbit hole, I am not sure this is a good idea, since you say you’re not a very technical user.

If you put the environment back to production, does the cache clear complete correctly? And do you get your system back?

Yeah in prod state, cache clear code worked.

But it didnt solve the issue i mention previously.

Dont know how lots of people using suitecrm without facing problem.alot of people using this with lots of user/agent.

It works for most people. When it doesn’t, we need to find out why, but we ran into problems doing that, in your case… sorry.

Do you have any further clues in the server side logs?

Note that suitecrm.log is no longer in the project root; in v8 you will find it under public/legacy

Basic information about your environment:

  1. Which OS? OS Version?

  2. Version of PHP?

  3. Type of database? Version?

  4. Try the things in this thread another cpanel user did and report back here your results:

Same problem, Cpanel, Clean install, php 8.0, 8.1, 8.2, tried solutions from above, no success.


2024-03-04 16:18:49] php.CRITICAL: Uncaught Error: Failed opening required ‘/home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/getCurrencyPreferenceMapperService.php’ (include_path=‘/home/xxx/public_html/stage3/public/legacy/include/…:.:/opt/alt/php82/usr/share/pear:/opt/alt/php82/usr/share/php:/usr/share/pear:/usr/share/php’) {“exception”:“[object] (Error(code: 0): Failed opening required ‘/home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/getCurrencyPreferenceMapperService.php’ (include_path=‘/home/xxx/public_html/stage3/public/legacy/include/…:.:/opt/alt/php82/usr/share/pear:/opt/alt/php82/usr/share/php:/usr/share/pear:/usr/share/php’) at /home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/App_KernelProdContainer.php:547)”} []

[2024-03-04 16:18:49] php.CRITICAL: Uncaught Error: Failed opening required ‘/home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/getApiPlatform_Listener_Exception_ValidationService.php’ (include_path=‘/home/xxx/public_html/stage3/public/legacy/include/…:.:/opt/alt/php82/usr/share/pear:/opt/alt/php82/usr/share/php:/usr/share/pear:/usr/share/php’) {“exception”:“[object] (Error(code: 0): Failed opening required ‘/home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/getApiPlatform_Listener_Exception_ValidationService.php’ (include_path=‘/home/xxx/public_html/stage3/public/legacy/include/…:.:/opt/alt/php82/usr/share/pear:/opt/alt/php82/usr/share/php:/usr/share/pear:/usr/share/php’) at /home/xxx/public_html/stage3/cache/prod/ContainerJBz5k0e/App_KernelProdContainer.php:547)”} []

Browser console, when trying Quick repair and rebuild:
GET 500 (Internal Server Error) polyfills.b06f30c758be4076.js:1
POST 500 (Internal Server Error) polyfills.b06f30c758be4076.js:1