8.2 Report undefined field headers

I’m having a similar issue to those I’ve seen elsewhere on this forum (7.10 Report fields header shows "undefined" - #15 by elsaadj, Undefined columns when creating charts in report module, Problem in the Report module with thead appear undefined etc)

After upgrading from 7.13 to 8.2, the column headers on Report Parameters are all showing as ‘undefined’

In addition, the selection box fields which used to be large enough to view several options at once are now only one line high: (image is previous 7.13 state)

I’ve tried running some Repairs - the javascript repair showed undefined after about a second

I’ve also tried altering the permissions and it didn’t help.

I’m not sure if the following javascript console errors are related:

[HTTP/1.1 404 Not Found 44ms]

Loading failed for the <script> with source “https://rs.com/public/legacy/cache/jsLanguage/en_us.js?v=VwhUpIevrhrBTns5MdqZow”. index.php:35:1
[HTTP/1.1 404 Not Found 46ms]

Loading failed for the <script> with source “https://rs.com/public/legacy/cache/jsLanguage/AOR_Reports/en_us.js?v=VwhUpIevrhrBTns5MdqZow”. index.php:35:1
[HTTP/1.1 404 Not Found 8ms]

Loading failed for the <script> with source “https://rs.com/public/legacy/cache/jsLanguage/AOR_Conditions/en_us.js”.

But I get similar console errors on all pages.

PHP 8.0.28
Mysql 8.0.32
Apache 2.4.56

Please check your public/legacy/.htaccess file.
if there is something like

RewriteBase /xxxx/publiclegacy/

importantly publiclegacy without a slash between them. Replace publiclegacy with public/legacy

1 Like

Thank you! That fixed the undefined headers :smile:

1 Like