Why Blank Page And No Access After Small Changes?

Hello…don’t know why every time I make small changes, after a few minutes or seconds, the site turns blank. Ive reinstalled software 5 times. If I completely remove the top left image from the server to remove the logo from appearing, it goes blank. I put the images back but site is still blank.

Im installing this directly from softlicious on the server. It installs well and don’t seem to have issues until I make minor changes. Is there some thing Im doing wrong or a file I need to edit. I have flushed all cache on browser & server, still no luck. Im going to reinstall again but would like to figure it out so I don’t keep installing.

I really like the software and fits my needs.

Thank You

You should try to look in your logs to see what’s really going on. See my blog below for a post explaining where the logs are.

Possible explanations for your problems:

  • maybe your permissions aren’t set correctly (very common issue)

  • maybe your PHP has an insufficient max_execution_time or memory_limit set in php.ini

Come back here and tell us when you have more info. It might also help to let us know your versions (OS, database, web server, PHP, SuiteCRM).

Thank You, will try this out…

In code there are no “small changes”, just errors or success editing.
So what was your changes? Did you edit any code file?

Hello, I removed the actual logo in the Theme directory so that it won’t show up at all. In another instance where page went blank, I changed the word Employee to agents, just on the second portion of the code example ‘Employees’ => ‘Agents’, just the second portion of code to display a different word. Once it gave me a blank page, after another install it did not, then I removed the logo afterwards and it did…

I have contacted the hosting company and they are looking into making sure the permissions are correct per the installation instruction.

I can not post a log as I have no access to admin section either

Thank You

It could be permissions problems: if you edit the file and it gets special permissions that the web server can’t use, that file will effectively “disappear” for the web server and your site will break.

It’s very possible that the way you’re editing either changes ownership of the file, or removes write or execute permissions from the file. You should be able to (at least) check which file owner and permissions are applied to each file, even from a File Manager.

Thanks pgr…I have looked at the Wiki installation guide to see what permissions should be set for certain files. I only thing I find is

sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

I requested my host to check and see if they are set correctly.

From what I read on here, to change the Employees to Agents, the language file would be the one to change, but I might be doing it wrong, possibly there is a way to change it on the admin. Will search again to see if there is a better method…

Those are the permissions settings to begin with, to install. Sometimes they might need to be repeated.

But your description sounds like things break when you edit the files. If you just change the contents of a label, the app shouldn’t break. So, how are you editing the files? And do you see a change in their ownerships/permissions between before and after you edit them?

Ok, maybe the way Im editing them is what is causing the issue.

FTP client, find the file in the directory, example language php, open it, edit and reuploadvia ftp, for the logo, FTP, find it on the directory and delete image…When I reupload, ftp does not ask to set permissions, maybe its getting reuploaded and permission change without me knowing…

Is there a way I can change label via backend?..

Thank You

I don’t know what your service provider lets you use, ideally you would have an SSH shell, or at least some administration website where you could use a console or a file manager, and perhaps a file editor.

The file manager would also let you see (and perhaps change) permissions.

I use Filezilla, it lets me see permission if I want, but the only permissions I know of are the ones in the installation Wiki which as is for the initial installation.

I would not know if that language php file has been reuploaded with the right permission or not…If you can point me to a guide I can read it and check the permissions of individual files or directories…

Right now the en_us.lang.php is set at 644 ( This time when page went blank with was due to removing the logo not editing the language file )

Thank You

Filezilla is not a File Manager, it is an FTP client and I’m a bit suspicious of trusting what it says regarding handling of permissions, not because of FileZilla, but because of your service provider which might be restricting what can be done from FTP.

The required ownership and permissions are those stated in the wiki; the question is whether these stay the way they are, or whether they are degraded when editing a file from FTP.

If you have 644 then that isn’t either 755 nor 775 :slight_smile:

However, even if your permissions are not ideal, you can at least determine if they are degraded when editing or not. if they are not, then your edit didn’t cause permissions problems, it caused other problems.

Just wait for your service provider to fix your permissions… or ask them if they will let you have SSH access, or CPanel access.

Thank you…So seems the issue is the file permissions when I edit and reupload the files…The host already replied that everything was correct, as you mentioned, those permission are for installation and installation has no issues…Im going delete and reinstall, when I edit a file, I will check the permission and set the reuploaded file with the same permissions…If does not work with FTP will do it thru Cpanel…

Thank You for your replies, helped me figure out where the issue might be…I really like the software and just need to get it working right before I have all my agents start using it…

What editor is associated with PHP file in filezilla?
Do not use windows notepad but a proper editor like Notepad++ https://notepad-plus-plus.org/

Thank You horus68…Filezilla uses regular notpad as editor…Will use Notepad++ on new install when I make the changes…

Thank You all for your replies. I did a new installation. So far all seems well. This time I made a few changes with Cpanel instead of via FTP. I changed the language php to display “Agents” and worked. I created a new logo for the top left and replaced them via cpanel with the same exact name, the new logo does not appear but the link to suitecrm stays, no biggie, Im not going to figure out why, might be my image size of something. I just removed the

on the login.tpl file and actually removing the top bar blends in better with my site…

So seems the issue was editing the file via FTP…

Hopefully this thread helps other ppl when they search that might have same issue…

Again, thank You much…