Undefined popups

I have the old undefined popup message problem

I cloned a SuiteCRM instance and the new one has undefined popups

I cleared the cache and change permissions but still no joy

Any ideas?

For example in list view on the original it popus up Loading Page please wait but in my cloned instance I get undefined

Can you double-check the permissions?

Remember there are many sides to that story:

  1. permissions on files and directories
  2. ownership on files and directories
  3. how permissions are inherited for new files and directories (setGID bit)
  4. which user your web server runs under
  5. which user your cron jobs runs under

Definitely not the permissions

They have been checked and double checked

Ownership is also correct

I can’t tell you how many times on these forums somebody promised they had their permissions right, and turned out later that one of the above aspects was completely overlooked…

But ok, I have to trust you :slight_smile:

A couple more ideas:

  1. Did you fill in default_permissions and ownership in config.php?

  2. Try deleting cache/themes, it will get recreated and might solve some transient problem

I know what you mean about the permissions but it isn’t the problem in this instance - wish it was

Deleting the cache makes no difference

default_permissions are set in config.php

It appears to only be the system popups that are affected

Do you see anything in your logs (both suitecrm.log and php_errors.log) at the time of the “undefined” error?

What about in the browser’s developer console, is there anything there?

I get a “403 forbidden” error when accessing it, but maybe your site isn’t supposed to be public on the web?

This sounds basic, but have you tried from other browsers / other computers / other networks?

Maybe there is some other level of caching interfering somewhere…

I can access the files by clicking on the links - not sure why you can’t

I have tested it in multiple browsers all with the same problem

Cache on browser has been cleared

The Instance I copied this one from works

If you can access internally, and I can’t access externally, I would look for any firewalls / web server configuration problems.

You can probably test it simply by clicking those links from your mobile while connected through mobile data (different network).

Yup I get the same error if I try and connect externally but that may be a red herring as I get the undefined issue internally

Also 2 other Sugar sites on the same server using the same http.conf work properly without the undefined issue

Maybe you can try the other repairs in Admin related to rebuilding Javascript.

But keep looking for web server configuration issues, web caches, firewalls…

I have tried all the repairs :frowning:

Have you updated the .htaccess file after cloning your instance?
It contains some reference to a local path so, if you clone it you also have to change that reference in .htaccess.

check also config.php for paths and urls

I’ve literally just checked the .htaccess file :slight_smile:

That was the problem

Feeling a bit of an idiot ast the moment

Almost every sysadmin problem looks idiotic once discovered, but before discovery… that’s the hart part :slight_smile:

The important thing is that your problem is solved!

… and that I can add another case of “I swear Ive looked into every aspect of permissions and they’re fine” to my list :slight_smile:

although I must admit I didn’t mention that one here.

Not the permissions :slight_smile:

Just completely forgot the .htaccess file

Ended up doing a search for any file that included the instance I had cloned it from - wish I had done that on Friday

Please solve my problem too. undefined errors in popups in studio ?

Do rebuild your .htaccess file. It can be an issue of rewrite base path.

Admin->Repair-.Rebuild .htaccess file

Yes you are right it solves the issue. Can you please help me in another issue.I am editing sub panel (Documents) of contact modules but its get reset after save and deploy. Please help

Do you mean you are changing files by hands or via studio? Please elaborate your question. May be by screenshot or small video.

Thanks & Regards,
Team Urdhva Tech