Undefined - lots and lots of undefined

If you have a read of SuiteCRM 8.0.4 on Ubuntu 20.04, apache2, mariadb, php-8.0 fails with validation errors - SuiteCRM Forum - English Language / Installation & Upgrade Help - SuiteCRM, Mac-Rae posts what should be a workaround, but it is not, unfortunately.

In SuiteCRM 8.0.4 and 8.1.0, because of the “SuiteCRM 7.x Legacy install” that SuiteCXRM 8.x is running on top of (in some way I’m still not sure about), you need to edit the suiteroot/public/legacy/.htaccess file and add “/public” in front of “/legacy” to allow the rewrites to work properly, and this should remove the “undefined” labels from appearing almost everywhere in Studio.

It most definitely did work in 8.0.4, but doesn’t work at all in 8.1.0 - with or without this change, “undefined” makes itself known almost everywhere in Studio.

I’ll also just add that after seeing the “undefined labels”, I added the “/public” to the beginning and noticed no change (yeah, restarted Apache). I have just gone and removed the “/publix” prefix, restarted Apache and it seems to be working better now. Who knows…

I’ve seen this in the past and didn’t have to restart Apache.
Since a lot of people run this on shared hosting it can also be resolved by running the repair scripts Login, go into Admin, scroll down to Repair, and click on it.
Run the quick repair.
If you still get that, then go back and go down the list and run the various repair options.
The other thing I’ve seen happen is file permissions are set wrong on the directory and files.

Permissions are all good (I’ve played that game before, and lost). :). It seems to be working fine for me now. Weird… (Happy, but weird.)