Unable to find relationship projects_contacts_resources

Hi

I recently upgraded from 7.14.2 to 7.14.3 on my development system running on php 8.1.13 on MAMP on mac.

Install completed without errors, however after install I noticed that the links on the global search results were not working. A quick look at suitecrm.log shows several lines of the following after each search;

23:42:08 2024 [50831][1][ERROR] Unable to find relationship projects_contacts_resources
Sun Jun 2 23:42:08 2024 [50831][1][ERROR] Unable to find relationship am_projecttemplates_contacts_resources

Maybe it’s a permission issue, so I ran the usual;
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chmod 775 config_override.php 2>/dev/null

No change.

Does anyone have any idea what could be causing this error or how to fix it please.

Thanks Terry

I have spent a day on this problem and have got no where!

  • Reset permissions in case I mistyped something.
  • Reset cache.
  • changed back to php 7.4.33

It looks like the fields; projects_contacts & am_projecttemplates_contacts are created when the CONTACTS bean is created. The ‘-resources’ part is added at some point and then a non-db relationship is created. But this cannot be found and throws an error. All VERY confusing to me.

Having not made progress I thought I’d go back to 7.14.2. I had previously saved a copy of the full directory.
Now it seems I have the same problem with the previous version!! Arrrgghh.
How can this be??? Has something changed in the DB?

What am I missing here? Can anybody PLEASE suggest anything before I go completely loopie.

Thanks
Terry

Have you tried Admin / Repair / Repair relationships

As in life, we must repair our relationships every once in a while

Suite should detect when it fails to find a relationship ([ERROR] Unable to find relationship projects_contacts_resources), fix the problem: automatically and silently run Admin / Repair / Rebuild Relationships, and try again to do what it was doing.

Or, with every Upgrade, as the last step, run the Rebuild Relationships.

Then, this bug would not impact users anymore.

Around the world, millions of hours of total downtime would be saved, for millions of users!

Thanks Chris & pgr,

yes I had done the Admin / Repair / Repair relationships several times. For good measure I just ran them again, but no cigar.

I still get multiple of the following on every global search;
Unable to find relationship projects_contacts_resources
Unable to find relationship am_projecttemplates_contacts_resources

From what I can make out, these relationships don’t exist in 'cache/Relationships/relationships.cache, which is why the errors occur.

Deleting this cache file to force rebuild results in the new cache file also not containing the relationships.

Something seems to be disable or missing somewhere. Any ideas please?

Cheers
Terry

This might help understand:

You can also check the fields_metadata table in the database.

Make sure you have backup of the table before messing with it, things might break

Thanks guys, will check these out.