Two-way sync for SuiteCRM Calendar to Google Calendar

Would be possible to have a two-way sync for SuiteCRM Calendar to Google Calendar? or Google Calendar to SuiteCRM?

Yup, if you go into your profile > Advanced there is a section called Calendar Options this should have all this information you need to link up the calendars :slight_smile:

If you need more direction on how to link it from the ical url to the google calendar just ask

I already copied or link the iCal integration URL to the Google calendar but the meetings that I created on the SuiteCRM Calendar won’t display in the Google Calendar.

Can you please provide the steps you took to add the ical URL to your google calendar?

Not sure if I have this correct, but here are my steps
Not sure if this allows for two sync?
The meetings I put in SuiteCRM are not immediately showing up in Gmail.
Not sure what the refresh times are

Log into gmail
Select Calendar
Select Cog(options)
Select Settings
Select ‘Calendar’ from the top tabs
Select “Browse interesting calendars »” from the near the bottom right under the “Other Calendars” section
Then
Top right under “More Tools”
Select “Add by URL”

Paste the URL from your SuiteCRM >> Profile>>Advanced Tab >> iCal URL

eg: http://contact.domain.com/ical_server.php?type=ics&key=9613f-54-09-5d5-580c5&email=dave@domain,com

Select Add Calendar
Okay all done, where is it?

Select “« Back to calendar” in the top left
Now you can see the Calendar reference under "Other Calendars’ and you can give it a color.

After its set up I can see back under “Other Calender” more options for ‘notifications’

Steps:
1. I log-in to the SuiteCRM.
2. Go to profile then advanced tab.
3. then i copy the iCal integration URL.
4. paste it on the Add by URL in Other Calendars using the Google Calendar

Could be possible Google event in calendar to SuiteCRM calendar using ical?

Running version 7.8.1 on a Debian wheezy server in our office. I opened up a www port and pasted the ical link into Google. Connection was successful, but none of my tasks are syncing. The meetings I had entered in SuiteCRM synced over but not the tasks.

Is it possible to sync all entries in the calendar, or only meetings?

Also, even though the calendar is shared to google, I cannot modify the calendar from google. How can I edit permissions on the CRM side to allow two-way sync with google?

Too bad we can’t edit our posts here, right?

Anyway… Found another problem with my shared calendar. Google isn’t receiving the time zone from CRM. On google the calendar time zone is (GMT+00:00) GMT, but in the CRM it’s -4:00 New York/America.

I’m digging around in the SuiteCRM folder on our server for config files. I’d sure appreciate any help in solving these issues.

Anytime this is planned to be fixed? The two way sync with google calendar for all entries of SuiteCRM? That would be fantastic!

I’m giving it a shot. It’s going to be quite a project for me.
https://github.com/salesagility/SuiteCRM/issues/6043

2 Likes

Is this available as an Installable Package which we can add to existing CRM. As there are no clear indications from SuiteCRM when they would merge this to master and allow everyone to use it, can the files be pointed out so we can cherry pick them to add to existing system.

@benjamin.long Hats off to your effort and the contribution to community.

I’m not sure where my problem is so I’m gonna ask here and if it needs to be asked elsewhere, maybe a mod can move it(?).

First of all, I am running SuiteCRM 7.11.1 on an Ubuntu Linux system.

I have read the docs but I have one huge stumbling block, there is no place in System Settings for the Google Authentication(there is no entry below the Proxy Settings as is shown in the docs). I can see the stuff regarding Google Suite but something I’m doing there isn’t working right either as when I select the json file, it doesn’t seem to upload, even when I click save because it still says that it’s unconfigured.

Do I need to have something else configured to get the Google Authentication to show?

Any insights appreciated.

Ok, I tried installing benjamin’s github version of this and I’m still not showing the Authentication stuff on it either. At this point I’m at a complete loss because I have searched the code and the code for this seems to be there but for some reason isn’t enabled or showing.

It’s been moved. Unfortunately whoever moved it didn’t update the Docs to reflect it. I’ll see if I can find time to fix that.
It’s further down in the Admin page, where Google things have been given their own section.

https://i.imgur.com/ZdsVhfP.png

What you’re looking for is under ‘Google Calendar Settings’.

Well at least I wasn’t crazy trying it. I still can’t figure out why it won’t accept my credentials.

I searched the code and it shows the url as “/index.php?entryPoint=saveGoogleApiKey&getnew”, is that what I should use or do I cut off the “&getnew”?(I’m assuming cut it off but it’s always wise to ask). I’m not entering a partial URL here, I’m just wondering if I have done that part correctly as well. If all of that is correct then I have no idea why it won’t configure because I’ve followed the instructions.

The URL from the docs is correct:

https://i.imgur.com/sW6pZo0.png

I’m not sure where you’re seeing &getnew.

The “&getnew” is shown in SuiteCRM’s code for the entryPoint. I searched for it to make sure I had entered the URL correctly.

Well I’m at a complete loss then. I have no clue why it won’t configure. I’ve followed the instructions and it never says it configured, and unless the calendar stuff for the user isn’t in the Advanced profile tab any more, it’s definitely not showing. Hmmph, any ideas beyond what I’ve tried? Do I need to configure the consent screen at all? I did so just in case but still get nothing(though I didn’t tell it to verify my domain, etc.)

Ok, well I just discovered that the Google Authentication thing does NOT show up on the Administrator account but does show up on my user account(that is also an admin so I didn’t think to look) but it says “The current API token is DISABLED”, so I’m guessing I have to see why it isn’t actually getting the JSON file.