Suitecrm instance only shows login page on aws ec2 instance

ok all the credentials are right here but what should i write in this ??
‘db_host_instance’ => ‘’,

Whatever you are using to host the DB, mariadb, mysql or mssql are the 3 main ones

All the credentials are right sir now what we can do ?

Ok so you’ve added the DB host? and its still the same? Just white screen and database error?

only header is showing

Next best bet is the apache2 logs, can you run ls -lha /var/log/apache2/ and send me a screenshot of the results? The last-minute or so of the suitecrm.log (in crm root) would also be useful.

My suitecrmlog file is not updating why is it so ?

Not sure, lets not worry about that. Could you give me the screenshot of the dir so we can decide on what apache log we need

ok i am sending you the screenshot just a minute

Nether of those screenshots appear to show me what we need? I thought you had terminal CLI access on a linux system? ls -lha /var/log/apache2/ can be run and then printscreen would be great

is this helpfull ?

Please could you run the ls -lha command as it gives more detail
It also looks like apache2 doesn’t exist there.

Give me 5 to do some googling

after running above

ya please take time so that this get solve this is mysqld.log file

Ok, follow these commands exactly. Stop if you encounter any errors and let me know where it stopped along with the error it produced.

  1. cd /
  2. sudo su
    (Type the password for sudo)
  3. cd /var/log/httpd/
  4. ls -lha
  5. Take a screenshot of the on-screen output

ok just a minute let me do this. All commands run successfully Please have a look

Great from there run the following;

  1. tail -n 200 error_log
  2. Copy the tags below into your reply
  3. Copy the outputted logs into the PASTE_IN_HERE section
[details="Apache2 Logs"]

i didn’t get you sorry . i ran command of step 6 and sending you the screenshot.

Alright, could you do one more thing? Navigate back to the root directory of the CRM
cd /var/www/html/suitecrm/ and run this command;

  1. chown -R www-data:www-data /var/www/html/suitecrm/
  2. Check the status of the CRM and what it looks like
  3. Press in rapidly CTRL+R within the SuiteCRM tab 10-15 times to clear cache
  4. Again check the status of the CRM and what it looks like

after typing command it says “missing operand after ‘www-data:www-data’”