Suitecrm instance only shows login page on aws ec2 instance

Hello all
I deployed my Suitecrm instance on AWS EC2 but it shows only login page after then it don’t works. It works fine in Cpanel all the permissions are also fine any idea ?:disappointed:
i don’t know what’s the problem is . It again says database failure please refer suitecrm logs. All the permissions are now proper set it working fine in cpanel then ??? Please help


Hi @namitkakusuitecrm,

Is your database hosted on the same server? If so can you ping, curl or use the mysql command to connect to your database?

Additionally, did you have a look at the log? Can you copy+paste the messages?

i was not able to enter in the system how can i see the log file sir

yes sir database is also on same server. how can i ping and check sir can you please tell.only i am getting this error in console

4(index):35 GET http://–.--.–.--/suitecrm/cache/jsLanguage/Home/en_us.js?v=yjyouUPb4e_NYIsRM2RceA net::ERR_ABORTED 404 (Not Found)

why every time this error my only deployment is left i am totally depressed.

Run a composer install --no-dev and let me know what happens

Where should i run this in aws ec2 ?

If you don’t have command line access then your guess is as good as mine

Running this command php composer.phar install --no-dev using a terminal within the root directory of the CRM appears to be the recommend way

1 Like

my project is in /var/www/html/suitecrm so should i run this command in html folder ? if i run inside html folder it gives “could not open file composer.phar”

so the folder in which the CRM starts which would be the suitecrm folder

i install composer inside suitecrm folder even its not working sir

Did the composer install complete?

yes installation is complete it gives message as composer gives in caps “COMPOSER”

Ok, next step for me is permission. Are you using a windows or linux based instance? As in powershell commands or linux terminal

linux based instance i am using putty to fire the commands

Can you run these one at a time?

  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

Let me know what fails

these commands should i fire inside suitecrm folder right ?

Yes, unless i say otherwise all commands i give you should be run from the root of the crm which would be the directory named SuiteCRM in your instance.

yes i ran all the commands no error

OK status of the CRM is the same? If so next step it to check config.php and ensure the details in there for the database are as expected;
Correct Password
Correct Username
Correct Host
Correct DB Name

Most likely you password or username has changed since the move so make sure the most recent valid one is included.