SuiteCRM 8 Convert Lead Button Missing

My SuiteCRM 8 installation is missing the “Convert Lead” action under the actions button?

I’ve tried the SuiteCRM 8 demo and it’s there in the demo. So it must be unique to me.

I’m on the latest version 8.1.3
I’ve rest my permissions
I’ve done repair and rebuild
I’ve rebuilt all my JS files
I’ve cleared the cache folder

I’m not sure what else to do or check. Still not 100% on how all this works in SuiteCRM 8. Checked the detaiview metadata file and the code for the convert action is there?

Oh and also the lead is not already converted (and I tried toggling on and off the option to hide convert action for already converted leads).

There are no errors in console. I’m not sure what else to try. Any ideas?

Hi @pstevens

In order to replicate the error, I installed version 8.1.3.

Then I created a Lead, and under the actions button, I have the “Convert Lead” button.
This action successfully created an Account and a Contact from the Lead information.


Thanks @domiserver I know this is a “me” issue. I tried in the demo environment and the convert lead works. Just can’t figure out why in my installation the button is missing?

OK, so I noticed my editviewdefs.php in my /custom/modules/leads/metadata folder was way different than the one in /modules/leads/metadata folder (and not just the fields customizations). So, I deleted both the detailviewdefs.php and editviewdefs.php in the custom/modules/leads/metadata. Then went back into Studio, checked, sync to detailview, and re-saved the editview layout. This created the two new viewdefs in the /custom/modules/leads/metadata folder and voila, now it works.

Not sure what happened, I had this from beta so maybe in the upgrades there was some snafu. Anyway working. Try this if it happens to you.