Studio bug

Problem with Studio.

When updating the layout in Studio of a module, when I click save, I need to refresh the page, as I cannot click on the close button of the dialog box.

This isn’t so much of an issue when I’m dragging fields, as I can refresh the page after saving it and keep going, but it is a major issue when I’m changing the title of a box as it opens in a new page, and then returns to the main layout editor meaning that I can’t save the layout, so the section title remains as “New Panel 1” or similar

I have updated to the most recent version, and also done Quick Repair, but the problem still exists.

Please assist me in fixing these niggly issues, as the continue to present themselves.

Does this happen similarly on the live demo?

If so, can you please post a screenshot so I see what you mean? Thanks

Yes, this happens on the demo as well. I have attached a video.


I’m getting the same issue since upgrading to 7.9.9

Hi, just taking a look into this issue now.

I have a feeling that I know why this issue has started happening.

Ill work on a fix just now.

I know how to fix it thoug, so i could explain the solution here for the moment if that helps?


Hi, sorry for the delay.

I have a feeling that I know why this is an issue and also that I know how to fix it.

I’ll work on a PR at the moment.

Would you like me to post a fix in this thread that you could use for the time being?

Thanks for raising the issue!

I have tried 7.9.9 and 7.8.10 same issue on centos and ubunto 16.04 php 7. Is a php 7 thing?

A fix, or explanation within this thread would be great! :cheer:

1 Like

Will do, I have already made a PR for this issue, so I will link it at the bottom and explain here too :slight_smile:

Another z-index issue casued the popup to be non accesible. By pushing the mask backwards by an index of 1, it should now allow for the popup to be clickable.

Please feel free to ask any questions here or on the PR!

Thanks again for raising this issue! :slight_smile:

I’ve just changed the z-index from 3 to 2, but am still encountering the same issue. I still can’t close the pop-up that occurs :frowning:

Oh, sorry to hear that.

The issue still occurs by replacing:

.mask {
z-index: 3 !important;


.mask {
z-index: 2 !important;


I’m not sure if this is helpful or not, but having used firefox’s development tools

There is a sugarMsgWindow_mask using a z-index value of 1

Having set as you detailed above the z-index of 2 to the .mask, I can see that sugarMsgWindow_c applies a mask of 2

Yeah, it seems strange. This seemed to work on my build using 7.9.9.

The inline style of the mask you are speaking about has a value of 1, but for some reason the file overwrites it to give it a value of 3 which is too large.

When you make the change in the file, does this value change if you inspect the element?

Maybe a hard refresh, css recompile and repair and rebuild could ensure that the index of 3 isn’t cached?


As per my message above, within the html I can see that the value of 3 is no longer there… Yet I still can’t hit the ‘X’ in the top right corner

Sorry to hear that, when you say it is no longer there, you mean it is replaced by 2, yeah?

And is the box still behind the mask?


It is replaced with a 2 yes… And seemingly still behing the mask (I assume the mask is the value of 1?)

Yeah, so the mask has an inline value of 1, but it gets overwritten with the use of important in the .mask method.

Could remove the !important and then it should use the inline style value?


I’ve just tried removing the !important and that did not change anything

I also tried setting .mask to 5 but similarly no effect

Are we definately talking about SuiteP / css / main.scss


Yeah, we should be looking to lower the mask index, as that refers to the greyed out box covering the popup.

Yeah, within main.scss, line 98~

Changing that to 2 should lower it enough to pu the mask behind the popup.

It seems odd, I have heard that this fixes it for others.

Could you possibly check one more file for me, just incase you dont have one of the PR’s included (which would be odd as im using a clean 7.9.9)

Could you check (themes -> SuiteP -> css -> editview.scss) And check that

/* popup in studio */
.masked .yui-simple-dialog {
// Overridding inline style
z-index: 16000;

is found in roughly line 5403.

if it says a z-index with important after it, the important key word will have to be removed.

Then the same rebuilds for css.


Mine shows exactly as yours in that file.