Renaming Relationship Label

I’m trying to rename the label on the relationship I created. If I attempt to do it under “Labels”, it just reverts to it’s old name on save. if I try to do it in the layout editor, it just reverts to it’s old name on save. I attempted to follow the instructions here: and when I got into the file, it was already shown in the array with the name I submitted that I wanted. I did try a quick-repair, but that didn’t help.

Any ideas?

You may try deleting the content of the cache folder (keep the folder and delete all what’s inside) then Quick repair and rebuild.

In addition have you set permissions correctly hroughout the whole of SuiteCRM? (in another post you mention only one folder).

Are permissions correctly set also in config.php?

Thanks for the reply amariussi! I believe all permissions are set correctly as I did the commands recently to take care of that recommended by the installation guide. I had assumed bitnami would do it for me, but it didn’t.

I’m not sure what you mean about permissions in config.php. Do you mean on config.php? If so, they should be good as they were part of the installation guide as well.

Any other ideas?


bump… can anyone help with this? I’m using it to specify a parent project… and right now the label is ‘projects’ which is super confusing for users.

In your previous post you say “I believe all permissions are set correctly” and after a few lines “they should be good”.

The problem is not what you believe they are nor what they should be. Did you reset them correctly AFTER you experienced the problem?
Unfortunately permissions get messed up if not set correctly or under a number of circumstances so it is better to keep an eye on them before things get messed up.
I understand that you are developing/testing new configurations with your production system so you should take a special look at permissions as well as back-up all the SuiteCRM files and Database everytime you attempt something so that you will be able to do a step back.

If you are on a Linux server you should issue the following commads to set permissions correctly:

sudo chown -R owner:group .
( Where the owner/group values are the user for your web server. )

sudo chmod -R 755 ,

sudo chmod -R 775 cache custom modules themes data upload config_override.php

Then you should edit config.php and look for file_permissions and:
set user and group with the correct values
set dir_mode to 1533
set_file_mode to 493

Thw following is the code:
‘default_permissions’ =>
array (
‘dir_mode’ => 1533, // this is the decimal value for 2755
‘file_mode’ => 493, // this is the decimal value for 755
‘user’ => ‘yourserveruser’,
‘group’ => ‘yourservergroup’,
( Where the yourserveruser/yourservergroup values are the user for your web server. )

Then edit include/utils.php and look for default_permissions (there are two instances in the file) and replace with the above code chunk (in utils.php user is erroneously referred to as chown and group is erroneously referred to as chgroup, so just replace the piece of code.

Furtermore: you can check the SuiteCRM log (it’s in the SuiteCRM base folder under the name sugarcrm.log)

Please report any FATAL errors if any

After the SuiteCRM log you can check the web server logs (their location depends on your hosting company)

In addition, if you explain more precisely and post some picture on what you are trying to achieve it may be of help to those trying to help you solve your problem.

What version of SuiteCRM are you using? If it’s not the latest version you should consider upgrading because there have been many bugs corrections.

Another thing you could try is disabling unused language packs because in many cases they have caused problems. My experience is that the English language pack works fine, but the others may cause problems.
To disable them go to Admin->Languages and drag them to the right box. On old versions there was also a blank language which caused problems as well.

OK, I understand… but I’m at a crossroads.

FYI… I’m on a bitnami stack of SuiteCRM. I have no idea what the ownership of the files/folders were before I changed them.

I did as you suggested and changed all the files/folders to be owned by the apache user/group (daemon:daemon)… and I set the file permissions as you suggested.

Problem is, now the files are not writeable through FTP when I’m logged in as ‘bitnami’ user (which is the only user that is allowed SFTP access).

I’m not a linux/ubuntu expert by any means… I’m pretty handy with PHP, however… so forgive my noviceness.


OK, so I’m now in a workable place, but I’m not sure if security is a concern… I added the bitnami user to the daemon group as a secondary group… I then had to upgrade permissions to 775 so that bitnami can write to the files in addition to daemon being able to write the the files. Since daemon is the apache user, and has full control over files and folders, I don’t necessarily see why giving all group users that level of permission would be an issue. But again, I’m a novice, so I’m not sure.


Here’s the problem with pictures…

I created a 1:Many relationship between Projects & Projects to allow for a parent-child relationship.

I then try to edit the name in Projects->Labels, but as soon as I click Save & Deploy it reverts to the old name “Projects”.

Quick Repair doens’t change anything, when viewing in detailview or editview it still just says “Projects”.

So then following the instructions here, I open the \suitecrm\custom\modules\Project\language\en_us.lang.php file, but it already has the desired value (see the last line in the code below)!

// created: 2014-10-30 14:18:37
$mod_strings = array (
  'LBL_AA_FILE' => 'AA File',
  'LBL_CITY' => 'City',
  'LBL_STATE' => 'State',
  'LBL_COUNTRY' => 'Country',
  'LBL_CATEGORY' => 'Category',
  'LBL_FACILITY_TYPE' => 'Facility Type',
  'LBL_DRAWINGS' => 'Avant Drawings',
  'LBL_ASSIGNED' => 'Assigned',
  'LBL_PROPOSAL_SENT' => 'Proposal Sent',
  'LBL_ACTUAL_PROJECT' => 'Project?',
  'LBL_PROPOSAL_RECEIVED' => 'Proposal Received',
  'LBL_DESIGN_DEVELOPMENT_SUBMITTAL' => 'Design Development Submittal',
  'LBL_SCHEMATIC_DRAWINGS_SUBMITTAL' => 'Schematic Drawings Submittal',
  'LBL_CONSTRUCTION_DOCUMENTS_SUB_1' => 'Construction Docs Submittal 1',
  'LBL_CONSTRUCTION_DOCUMENTS_SUB_2' => 'Construction Docs Submittal 2',
  'LBL_FULL_SUBMMITTAL' => '100% Submmittal',
  'LBL_BID_SUBMITTAL' => 'Bid Submittal',
  'LBL_EQUALIZATION' => 'Commissioning',
  'LBL_FIRST_USE' => 'First Use',
  'LBL_RECORD_DRAWINGS' => 'Record Drawings',
  'LBL_SCOPE' => 'Scope',
  'LBL_FEE' => 'Fee',
  'LBL_EXPENSES' => 'Expenses',
  'LBL_HOURS' => 'Hours',
  'LBL_PANEL_ASSIGNMENT' => 'Schedule',
  'LBL_EDITVIEW_PANEL1' => 'Project Notes',
  'LBL_DESCRIPTION' => 'Description/Notes',
  'LBL_EDITVIEW_PANEL2' => 'Statistics',
  'LBL_DATE_START' => 'Start Date:',
  'LBL_DATE_END' => 'End Date:',
  'LBL_FEE_BILLED' => 'Billed',
  'LBL_FEE_PER_HOUR' => 'Per Hour',
  'LBL_STATUS' => 'Status',
  'LBL_EDITVIEW_PANEL3' => 'New Panel 3',
  'LBL_FEE_BALANCE' => 'Balance',
  'LBL_ASSIGNED_BY_USER_ID' => 'Assigned By (related User ID)',
  'LBL_ASSIGNED_BY' => 'Assigned By',
  'LBL_NAME' => 'Name:',
  'LBL_DELETED' => 'Deleted:',
  'LBL_CONTRACTOR_ACCOUNT_ID' => 'Contractor (related Account ID)',
  'LBL_CONTRACTOR' => 'Contractor',
  'LBL_FEE_INCLUDED' => 'Fee Included In Parent',

I would try the following:

  1. delete the contents of the cache folder (not the folder itself) and then navigate to a page where the label appears to see if it is correct.

  2. Search through all of the SuiteCRM files for the label names you want to change so that you can locate all files in which these labels appear and then modify them by hand

Hotfix from Sugar fixed it. For some reason they don’t make them available, you have to request it and then you get a .zip which can be installed through module builder followed by a quick repair.

It is important, supposedly, that you only use the attached hotfix with this version:

SuiteCRM Version 7.1.2
Sugar Version 6.5.17 (Build 1220)

1 Like

Good to hear you solved it!

Hey. If anyone’s interested, here’s the hotfix for Sugar Version 6.5.18 (Build 1110). Works with my local instance of Suite 7.1.4

Thanks to sieberta for putting me on the right track.

I know that this is an old thread, but I’ve just run into the same problem on SuiteCRM 7.3.1 (based on CE 6.5.20). Does anyone have the hotfix that works with this version?

I have the same problem. Version 7.2.

Is there any official patch or workaround to solve this issue?

Looking at the patch uploaded in other posts i can see the only difference between the patch and the SuiteCRM “LanguageManager.php” file is this line:

Function: “refreshLanguage”

Original Array:

$lang_paths = array(


It should be like this:

$lang_paths = array(


The order of the last two lines is reversed. Unfortunately this change is not upgrade safe.

This fixed the issue of the topic for me (Using the latest 7.9 verision of SuiteCRM)


Made this change, cleared the cache folder and it worked perfectly.

Thanks @positiveit for the fix.

I’ve got the latest version of suitCRM and its not fixed yet …
Version 7.10.9
Sugar Version 6.5.25 (version de construction 344)

If I understand correctly, on every update I will have to re-change the code in LanguageManager.php cause the update will override it ? …

Still looking for an update safe methode, I’ve got to do this little change on every update.

Wow… new version Suite 7.11.20 still has the problem!

I still use the fix proposed by @positiveit after every update of the CRM lol