PDF Quotation Template - Broken Images

Hello Everyone,

I’ve been working on a custom quote template for my company. I started by loading the “Quote Sample” and modifying from there.

I changed the picture from the SuiteCRM logo to our company logo. The logo is displaying just fine in the PDF Template editor but when I try to “Print to PDF” a test quote the image shows as broken (red X) in the PDF itself.

Does anyone know what might be causing this?


from the PDF template right click the image and get the URL for it. Are there any Spaces in the name or path?

Also see if you can get image information from the PDF. This depends on your viewer.

Post your results here…


Hey, this is an old thread, but if others have this issue, I had this broken image in PDF templates and was able to fix it:
-make sure the image is in a writeable directory on the same server as your SuiteCRM install, not a link to an external website/ server (eg localhost/uploads/)
-make sure the image itself has the correct permissions. I’ve reapplied permissions countless times on our server, but a logo uploaded via FTP still had the default 644 file permissions. Change permission on the image to 775.
-use a relative path in the HTML link to the image, eg

Hope that helps.

1 Like

HI Dylan,

thank you… had a huge problem with adding images to pdf templates…for me I had to upload image to the main directory of my SuiteCRM installation

and then I could use the “add image” button, but just enter the filename, no /

that was the only thing that worked for me

I could though add logos from other websites with http://image-location

I was not able to upload images from google drive though

Hope this helps someone, after I sopent hours trying stuff :slight_smile:

Best D

1 Like

Thanks I solved with your suggestion in version 7.11.18