Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Once a day task reminder workflow?

I am trying to figure out if there is a way to have SuiteCRM email the task owner or project task owner at the end of the day as a reminder if the task has not been updated. Most systems have something like this and Sugar has the time exceeded option in the workflow editor, making something like “after 12 hours” a viable option.

Any thoughts?

Currently there is no support for recurring workflow tasks, but it has been mentioned several times as a requirement. It’s not currently planned for any releases but will be suggested for future releases.

How can I achieve the same result with work flows (sending out daily task reminders)?

This is what I have and it is not working.

Hi rmcguire,

The “greater than” property would not be the appropriate one in this situation. A “less than or equal to” operator may be more effective.
Keep in mind though, This would mean the workflow would fire on ALL Project Task records that hadn’t been modified in 1 or more days.

Thanks - I will test it out.

Doesn’t work - any other thoughts?

Hi,

The less than or equal to operator worked for me.

Did the Workflow Fail or not fire at all? You can check underneath the Workflow’s Detailview in the “Process Audit” subpanel

Thanks, John

There is nothing in the Process Audit panel.

here is the screen

Hi,

Nothing in the process Audit would mean the Workflow is not firing at all.

Do you have your schedulers/ cron job set up?

Regards, John

Yes, other workflows are running correctly.

Hi,
I have attached a screenshot of the Workflow I am testing with. It seems to work fine for me.
The only difference I can notice is that, in your screenshot, You have “greater than or equal to” while I have used “Less than or equal to”.

The only reason a workflow wouldn’t fire, other than schedulers not being set up, is that either the Conditions are incorrect or their are no records that match the conditions.

Thanks, John

no screen shot attached :slight_smile:

My bad. Edited the post above to include screenshot.

Thanks, John

Still no joy. I’ve even deleted the workflow and re-created it to your screen shot and it never fires (even though other work flows work just fine)

Hi,

Are you sure there are records that meet the conditions? (Have not been modified in 24 hours AND are one of “Not Started/In Progress/Pending Input”

How many workflows are running each time the scheduler runs? If there are a lot then it could be simply timing out before reaching this Workflow.

Also, could you post a screenshot of the new workflow you have created?

Is there any script or back end tool to see if there are matching records at any given time?

Gathering the screen shots

Tue Sep 8 17:45:02 2015 [28056][1][FATAL] Job 475e76dd-a552-9eff-5225-55ef562eeb32 (Run Scheduled Reports) failed in CRON run
Tue Sep 8 17:46:02 2015 [28133][1][FATAL] Job 553a47f5-a15c-fd7d-3d7d-55ef571930c3 (Run Scheduled Reports) failed in CRON run

Getting this in the logs…

Version 7.2.3

Sugar Version 6.5.20 (Build 1001)

Hi,

For the time being, since this scheduler is failing, You can go in to Admin > Schedulers and set the “Run Scheduled Reports” to Inactive. If it was failing regularly it may be causing high server load. You could try a Quick Repair/Rebuild and attempting to see if your Workflow fires after “Run Scheduled Reports” is disabled