Not able to configure users email id in the profiles Microsoft 365 email

SuiteCRM 8.1, when i am trying to configure my email setting in the users profile with Microsoft account getting error incorrect user name and password where as i was able to configure gmail account.

did anyone had similar issue

1 Like

Yes, and you can use the Search function on these forums to find them :+1:

Thank you for posting this issue. I’ve been working on suitecrm8 for couple of weeks.
First I’d like to mention there is no proper documentation for this issue. They just gave the generic guidelines which is useless.
I’ve successfully added my Gmail and office365 account to the profile.

For both type accounts there must be two-factor authentication has to be enabled because for security purpose Google and Microsoft both have removed the option that allow access to less secure apps from the settings.
Then have to create app password from the email account security section.
Then add that app password in the password section

Mail Account Name: AnyNameOfYourChoice
User Name: yourEmailId
Password: appPasswordCreatedOnYourEmailSecuritySetting
Mail Server Address: /
Mail Server Protocol: IMAP
Use SSL: **for gmail it's optional but for microsoft it is mandatory**
Mail Server Port: 993

After this when you click testsetting button. It will give you success message.

if you are using company email id then you have to ask email id group admin to enable two factor authentication and create app password, for you this option won’t be available.

Hi @yousuff
Please see: - Simple Steps to Configure Inbound Email Settings in SuiteCRM