New logo not allowed

Hi, just installed SuiteCRM locally for functionality testing and came across an issue. In the admin section, I can upload a new logo. I have tried several times, several different ways, and it fails every time.

The file format of the image must be JPEG or PNG. Upload a new file with the file extension .jpg or .png.

the problem is, I have tried both jpg and png. the image name is “logo1”, so there are no spaces (i read about that issue).

any ideas?

I believe The criteria it must fit are:

The image file format is either .png or .jpg,
The maximum height is 170px, and the maximum width is 450px,
There are no spaces in the filename.

You have said that the filename has no spaces, and you’ve tried with jpg and png.
However, try scaling your image down so it fits the size requirements and try again.
Once uploaded, You may need to log out, clear your cache and log back in to see the changes.

I had the same issue. I tried .PNG and .JPG including the allowed size but without success.

This way below worked for me so may give them a try:


just put in SuiteCRM domestically for practicality testing and chanced on a problem. within the admin section, I will transfer a brand new emblem. I even have tried many times, many alternative ways, and it fails on every occasion.

The file format of the image should be JPEG or PNG. transfer a brand new file with the file extension .jpg or .png.

the problem is, I even have tried each jpg and png. the image name is “logo1”, thus there are not any areas (I examine that issue).


this is my solution I don’t think is the best way but it’s a solution anyway.

I change the logo via FTP in /themes/default/company_logo.png for my image and that works.

If you have some questions about it, I’m able to help you.


1 Like

yes, i got a same issue that image cannot be uploaded… so i have to replace the image file at the theme folder

The size of my company’s logo is 960x320.

There is no way that I can get 450x17 (allowable size in out of it.

Is there anyway that I can change the allowable image size in SuiteCRM?

I am using SuiteCRM 7.6.4


That 17px mentioned above isn’t correct, he meant 170px, that’s the maximum height.

So just scale your logo down to those dimensions using any image program and it should work.

1 Like

Hi pgr,

Thanks for your reply. 170 is much better.

My current image has the size 450x150. So, it is within the limits.

However, I still have the problem on the login page.

Here is what I did:
admin --> system settings --> user interface section : click on “choose a file”.
I upload the file from my local computer (size 450x150)

I click save and logout. attached is the login page I can see. My image does not appear and SuiteCRM logo has disappeared. It only shows a question mark. Please see the attached file.

when I login again and go to system settings, I see “no file selected” Please see the attached image.

Can you please let me know what I am missing.

Thank you,

Cking, go to /custom/themes/default/images/ and check if you have the file there, if you don’t check your folder permission should be set to 775 recursively

best regards

Hi Mikebeck,

Thanks for the suggestion.

The file I am uploading is not in the folder : /custom/themes/default/images/

I changed the permission of the folder images in /custom/themes/default to 775 (not 755) and uploaded the file again but I still have the problem.

The image I am going to upload is attached here. As you see, the name and size are ok.

Thank you for any help you can provide.


/custom/themes/default/images/company_logo.png and working for me

you should run chmod -R 775 cache custom modules themes data upload config_override.php

Don’t forget file ownership also. It’s no good chmodding if you don’t chown properly.

You need to know what user your Apache server runs under, normally you can just get that from the other files that happen to have correct permissions,

Hi mikebeck,


I used the chmod -R 775 for

cache custom modules themes data upload config_override.php

and it is no working.

I noticed your screenshot as the option for languages. How do I get this option?

Please forgive my ignorance. I am new to SuiteCRM (I installed it just a couple of days ago).

Thank you,

I’m glad that you got it working

for translations check this post

best regards

Perfect! Thank you.

By the way, in my previous reply, I meant to say: it is now (not no) working. Sorry about the typo.


I solved this issue by the following way:

1. Login Page

For the logo on the Login Page I just replaced the company_logo.png in suitecrm/themes/default/images. I modified my image in Photoshop so I had the same Size like the SuiteCRM logo. I named my logo also company_logo.png, so I didn’t have to change some code.

2. SuiteCRM interface (upper left corner)

For setting a logo in the upper left corner, I did the following steps. I edited the file _headermoduleList.tpl in suitecrm/themes/Swisscom/tpls.
Specifically row 42.

Row 42 original: {$APP.LBL_BROWSER_TITLE}
Row 42 edited:

Then I added a small version of my logo (ex. company_logo_small.png) to the following direction suitecrm/themes/default/images. I used a .PNG with a size of 34x34 pixel. At my opinion its a good size for the upper left corner.

After that I copied the edited file _headerModulelist.tpls to the direction suitecrm/custom/themes/Swisscom/tpls. When the folder not exists or maybe just a part of it like suitecrm/custom, feel free to create all orders. Then place your edited file.

When its not working check your System Settings in SuiteCRM and delete the System Name.

Its working since version 6.x and still working on 7.6.4.

jeromeb, your instructions are quite nice and detailed, thanks.

I would just add a comment (or perhaps a correction): normally it’s a good idea to leave the original files alone, and do everything in the custom directory.

That means you would start by copying the files to the custom directory, and only then edit them there. Also your icon would go in the custom directory.

This way you can be sure that your customizations are getting picked up by SuiteCRM, and not the files in the original location. So you have an extra certainty that your changes are, in fact, upgrade-safe.

And you are sure that you can compose a clone of your system simply reinstalling a clean copy, then copying the custom directory, config files and database.

Install version 7.7 but the logo does not load and throws me an error saying:


You don’t have permission to access /custom/themes/default/images/company_logo.png on this server.
Server unable to read htaccess file, denying access to be safe

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

Can you help me?.

Me esta pasando lo mismo pero no solo con el logo sino también con toda imagen que cargo, se creo un producto y le subo imagen de producto pasa exactamente lo mismo.
Al decirle que abra la imagen en una pestaña nueva me carga este error:

I happening the same but not only with the logo but also with every image that charge, a product was created and upload product image is exactly the same.
By telling you open the image in a new tab charging me this error:

You don’t have permission to access /upload/mk100-sombra.png on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.”

Ya e cambiado los permisos a todas las carpetas que indican pero el error persiste.