Installing on ubuntu getting stucked on yarn build

yarn run build:core --verbose, like this?

I think it’s after the command run but yeah, might as well try it. CLI Introduction | Yarn

Hi @Hamza,

Your node version falls outside the supported versions. SuiteCRM 8.0 makes use of Angular 12.1.x and therefore requires node version 12.14.x, 14.15.x or a later minor version (We’ve fully tested with version 14, we’d recommend that one if possible!). Your issues should cease if you lower your version to match. The compatibility matrix will soon be updated to reflex this more accurately
and can be viewed from here.

Please let me know if this resolved your issues :+1:

@Mac-Rae Thanks, but lower the versions but still stuck on same line:

Please Check

Changed node to version 12.22 and now i got this error.

@Mac-Rae @samus-aran @clemente.raposo any idea?

Hi @Hamza,

From the message “Cannot call write after a stream was destroyed in stylesheet file …”

This looks like file permissions.

Others users also had a similar issues and was permissions.

Which user is running the command, root?

@clemente.raposo yes using root user.

also set these:
find . -type d -not -perm 2775 -exec chmod 2775 {} ;

find . -type f -not -perm 0644 -exec chmod 0644 {} ;

find . ! -user www-data -exec chown www-data:www-data {} ;

chmod +x bin/console

Hi @Hamza,

The problem may be that the users are different.

Could you try running the following please? And then trying running the build command again. Note: please don’t do this on a prod instance

chmod -R 775 .

yes after setting permissions: error updated

Hi @Hamza,

Good, making some progress.

that error seems to be related with memory


@clemente.raposo yes hopefully we’ll get it done, as i’m stuck here from past few days.

my server info:

Hi @Hamza,

By the way, could you try going to version 14, please? We’ve tested with that one, just to be easier for us to help out.

And maybe best to use the developer setup in a local environment. The angular build process can take a lot of memory

i tried that out already, on node version 14 and it stucks there for hours.
one more thing i couldn’t figure out how to use point 3 from documentation, is it compulsory ? Thanks

Hi @Hamza,

You mean this one? Yes, it is required

No, i’m using this one:

@clemente.raposo Thank man, increasing server memory works.
but now i’m stuck here:

Hi @Hamza,

No problem. By the way, are you installing using the developer guide, because you want to do angular front end customizations?

for the error, could you try with the ip?

Yes to do customizations,
Tried with ip also still same issue.

this url is working and by hitting this url it takes me to (http:///SuiteCRM8/public/legacy/install.php).

but when i hit this url , blank screen appears.

@clemente.raposo @Mac-Rae @samus-aran any help please?

Hi @Hamza,

Sorry for the delay in replying.

Regarding the DB connection issue the following might help

Regarding the blank page
That is usually related with a misconfiguration in mod_rewrite see issue on github

Please have a look at the following section of the documentation SuiteCRM 8 install guide - 1.3 Configuring URL re-writes

the following may also help:

Hope this helps