Installing on ubuntu getting stucked on yarn build

I’m installing it on Ubuntu 20.04
But it stucks on this line: yarn run build:core

Error Updated:

@clemente.raposo please help! Thanks

Hi @Hamza,

Sorry for the delay in replying.

I assume you are trying to setup a developer instance.

One thing to note is to upgrade node to version 14. (the compatibility matrix needs to be updated, already created a PR)

Other that this version mismatch the Developer install guide should be ok

Also, please make sure to always build common, core, and shell. One after the other and the he following order:

  1. Common
  2. Core
  3. Shell

Thanks for answering @clemente.raposo , my node version is already up to date.

My node version:

i tried by this command also : yarn run build:core , by runing this command it stucks on same line every time and after waiting for hours nothing happened.

Have you tried showing --verbose and see if there are anything glaringly wrong? :crossed_fingers:

yarn run build:core --verbose, like this?

I think it’s after the command run but yeah, might as well try it. CLI Introduction | Yarn

Hi @Hamza,

Your node version falls outside the supported versions. SuiteCRM 8.0 makes use of Angular 12.1.x and therefore requires node version 12.14.x, 14.15.x or a later minor version (We’ve fully tested with version 14, we’d recommend that one if possible!). Your issues should cease if you lower your version to match. The compatibility matrix will soon be updated to reflex this more accurately
and can be viewed from here.

Please let me know if this resolved your issues :+1:

@Mac-Rae Thanks, but lower the versions but still stuck on same line:

Please Check

Changed node to version 12.22 and now i got this error.

@Mac-Rae @samus-aran @clemente.raposo any idea?

Hi @Hamza,

From the message “Cannot call write after a stream was destroyed in stylesheet file …”

This looks like file permissions.

Others users also had a similar issues and was permissions.

Which user is running the command, root?

@clemente.raposo yes using root user.

also set these:
find . -type d -not -perm 2775 -exec chmod 2775 {} ;

find . -type f -not -perm 0644 -exec chmod 0644 {} ;

find . ! -user www-data -exec chown www-data:www-data {} ;

chmod +x bin/console

Hi @Hamza,

The problem may be that the users are different.

Could you try running the following please? And then trying running the build command again. Note: please don’t do this on a prod instance

chmod -R 775 .

yes after setting permissions: error updated

Hi @Hamza,

Good, making some progress.

that error seems to be related with memory


@clemente.raposo yes hopefully we’ll get it done, as i’m stuck here from past few days.

my server info:

Hi @Hamza,

By the way, could you try going to version 14, please? We’ve tested with that one, just to be easier for us to help out.

And maybe best to use the developer setup in a local environment. The angular build process can take a lot of memory

i tried that out already, on node version 14 and it stucks there for hours.
one more thing i couldn’t figure out how to use point 3 from documentation, is it compulsory ? Thanks

Hi @Hamza,

You mean this one? Yes, it is required