incomplete installation and cases module not working

hi,
I attempted to install on a RHEL 5 machine with Apche 2.2.3, PHP 5.2.6 and MySQL 5.0.77
changed permissions owner/group as recommended by installation manual
instal.php started normally, gave root user to SQL DB, gave existing user which i created for the suitecrm installation

Installation process however stopped after 4 steps and didn’t continue as the installation manual described.

Creating SuiteCRM configuration file (config.php)

Creating SuiteCRM application tables, audit tables and relationship metadata
Creating the database gtalice on localhost…done

Creating default SuiteCRM data

 Creating default users...   done
 Creating default scheduler jobs...   done

Thats all.

My main Issue is, that suitecrm seems to be working, i can login with admin account and start setup but the cases module is not loaded. I cant create cases and imported emails cant be assigned to cases.

Im grateful for any help… otherwise Ill have to bail on suitecrm and go back to sugar :-/

Hi Selenis,

The error(s) should be recorded in sugarcrm.log? If you post them or upload the file, we can have a look.

Cheers

Bruce

Hello, sorry for the late reply.

oddly in my second installation of SuiteCRM there is actually some error in the log

roughly 30 entrys like this:

Thu Mar 13 14:28:03 2014 [21092][-none-][FATAL] Query Failed: select securitygroups_default.id, securitygroups.name, securitygroups_default.module, securitygroups_default.securitygroup_id from securitygroups_default inner join securitygroups on securitygroups_default.securitygroup_id = securitygroups.id where securitygroups_default.deleted = 0 and securitygroups.deleted = 0: MySQL error 1146: Table ‘gtalice.securitygroups_default’ doesn’t exist

and then several of those

Thu Mar 13 14:30:07 2014 [10031][-none-][FATAL] Configuration variable date.timezone is not set, guessed timezone Europe/Berlin. Please set date.timezone=“Europe/Berlin” in php.ini!

I think I tried to install at 14:28 on that day, not sure anymore

any help will be appreciated!

Hi Selenis,

Try the list of installation fixes I suggested here. Let me know how you go.

Cheers

Bruce

Hi Bruce,

I’m not sure the thread you suggested has much to do with my issues but i tried to apply the suggestions I found anyway.

  • I have commented out the code section in the SugarFTSHooks.php and made a Quick rebuild and repair.
  • I have added the date.timezone line into php.ini and restarted apache
  • my.cnf (my.ini does not exist on RHEL5) doesn not contain a specification for the storage engine so I presume MyISAM is running since its the default engine for MySQL 5.0 (I couldnt change it anyway because the server I try to install SuiteCRM on contains our main databases and I do not wish to be lynched by our developers :wink: )
  • I haven’t added the Error Message line into php.nin because my problem is that I do not have any meaningfull errormessages

sugarcrm.log now shows no error messages and cases module is still not functional.
It seems it does not load at all, only “Import cases” shows any result, but creating a case from an imported email does not work and creating a new case from menuz also shows no reaction :frowning:

attached is the messages i got when making the Quick rebuild and repair in admin

:oops: dear Lord I hope I found the issue…

when I installed I unzipped the archive in the root directory of the virtualhost i set up for suitecrm
then I moved all files with mv * from the created SuiteCRM directory back to the root directory…

at least I thought I moved all files but i just made a ls -a in that Suitecrm directory and .htaccess has not been moved so SuiteCRM installed without .htaccess…

Ill try to reinstall with all the files over the weekend and come back to you.

sheesh :S

that was not it

still the same issues.

sugarcrm.log shows couple entrys like this:

Mon Mar 24 10:16:15 2014 [29368][-none-][FATAL] Query Failed: select securitygroups_default.id, securitygroups.name, securitygroups_default.module, securitygroups_default.securitygroup_id from securitygroups_default inner join securitygroups on securitygroups_default.securitygroup_id = securitygroups.id where securitygroups_default.deleted = 0 and securitygroups.deleted = 0: MySQL error 1146: Table ‘gtalice.securitygroups_default’ doesn’t exist

so on Installation a certain table is missing.

Installation script stops at creating cron jobs as with last installation.

no other error messages are shown in sugarcrm.log

still cases module is not working at all.

unless you or anyone else has an idea i’ll have to go back to sugar CE :frowning:

just attempted my last hope and tried to install suitecrm 7.0.1 with the same results :frowning:

just as an info.

installed sugar ce 6.5.16
installation progress at the end stopped at the same point as with suitecrm so i never got to the registration page but cases module seems to work properly.

also no error messages in sugarcrm.log this time

would an upgrade from sugarcrm to suitecrm work I wonder?

Based on your error message the problem is only with the security groups module, which is a 3rd part module created by Sugaroutfitters. In suiteCRM I would try to do a rebuild relationships then repair roles from the admin panel repair screen. If that does not work go into the admin panel and then the module loader screen and uninstall the SecuityGroups module, do a quick reapir and rebuild and see if the problem still exists. If that solves the problem then reinstall SecuityGroups.

Woops looks like SecurityGroups has been put in as a standard module in Suite so cant be uninstalled, Just try the repair roles then rebuild relationships.

hi andy, thank you for your quick reply.

sadly it didn’t work

I tried the first step and the report is attached to this post.

I couldnt deinstall the securitygroups module because Module Loader shows no installed extensions.

Is you installation of suiteCRM on an open url?

I believe I followed the installation instuctions to the point. set permission and ownership correctly.
I gave root access to suitecrm and specified a particular mysql user and the database name
Installation check showed no warnings.
because the server is in a subnet to our local network which we access through IPSec VPN and there is no DNS defined i set the address to the server as localhost

Ive chosen not to populate the DB with demodata.

no its in a subnet of our local network via VPN to our webhost.

but I could change the firewall and iptable of the server to give you access if you give me your network address.

Im not sure what to advise in this situation. You could install suitecrm on different machine such as a local pc? Then if it installs 100% correclty you can copy over the database to your server and then copy over the files, edit the config to match the url and database on your server, do a repair and rebuild and you should be good to go.

well I have a Ubuntu 13.10 working station here but PHP, MySQL and Apache are updated to their latest versions.

butt Ill try and report back.

I really want Suite CRM to work :-/

That should work but you will get lots of Strict warnings etc… just suppress them.

Hi selenis

Have a look at the tables in the database that you have installed into. If the storage engine for the tables is InnoDB then that is the root of the problems you are having. If not, let us know.

Cheers

Bruce