Inbound email create case does not work

i have created a group email : sales@domain.com in “Inbound Email”
i configured all the email fields (like server, email address, folder name etc)
so email is working :slight_smile:
BUT …
i confgured also “Create Case from Email” but this does not work

Hi,
welcome to the Community! :tada:

Is your cron.php being executed regularly (like described here)?

crontab -e: (as root)

          • cd /opt/suitecrm-7/apps/suitecrm/htdocs; php -f cron.php > /dev/null 2>&1
            

when I do ls -al in /opt/suitecrm-7/apps:

drwxrwxrwx 5 root daemon 80 Dec 5 21:28 suitecrm

config.php

‘cron’ =>
array (
‘max_cron_jobs’ => 10,
‘max_cron_runtime’ => 30,
‘min_cron_interval’ => 30,
‘allowed_cron_users’ =>
array (
0 => ‘daemon’,

crontab -e -u daemon

          • cd /opt/suitecrm-7/apps/suitecrm/htdocs; php -f cron.php > /dev/null 2>&1

can some help me with this problem

Can you check if your corn job is running? you can find traces of this in Linux syslog, or in SuiteCRM / Admin / Schedulers, enter each job, and see if any of them has a Last ran successfully which is recent, and in the correct timezone.

in crontab I added Time Zone for crontab root and daemon

          • TZ=“Europe/Amsterdam” cd /opt/suitecrm-7/apps/suitecrm/htdocs; php -f cron.php > /dev/null 2>&1

in SuiteCRM / Admin / Schedulers I checked, but there are not any log !!
strange

Sorry, I don’t understand your answer.

Do you have any scheduler job showing a Last ran sucessfully time?

I checked scheduler: no not any scheduler job showing a Last ran sucessfully

“Last Successful Run: Never” for all jobs

Ok thanks.

First, remove the root crontab entry if you haven’t done it already.

Leave just the entry for the daemon user.

Then: do you have shell access? For example SSH console? If so, what do you get when you enter these commands?

which php

locate php

php -i | grep "'_'"

sudo find / -name php 2>/dev/null

These are all ways to find out the same thing, but sometimes one doesn’t work and the other one does, I am just saving ourselves some posts and replies, asking everything in one go :slight_smile:

./use_suitecrm


bash-4.2# which php

/opt/suitecrm-7/php/bin/php

bash-4.2# php --version
PHP 7.3.11 (cli) (built: Nov  8 2019 13:58:17) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.11, Copyright (c) 1999-2018, by Zend Technologies

outside console:

[root@moods4u-opr-2 ismet]# php --version
PHP 5.4.16 (cli) (built: Nov  1 2019 16:04:20)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

 so there are two versions: inside suitecrm-7 console  php7.3.11
and outside php-5.4.16

What is this you’re talking about, inside console and outside console?

You don’t provide the answer to most of my commands. I am not just looking to find out PHP versions (thuogh that is important too), I am looking to determine the exact location of PHP executables.

bash-4.2# which php

so the location is:
/opt/suitecrm-7/php/bin/php

[root@moods4u-opr-2 suitecrm-7]# find /opt/suitecrm-7/ -iname php
/opt/suitecrm-7/apps/suitecrm/htdocs/vendor/mikey179/vfsstream/src/main/php
/opt/suitecrm-7/apps/suitecrm/htdocs/vendor/mikey179/vfsstream/src/test/php
/opt/suitecrm-7/apps/suitecrm/htdocs/vendor/phpunit/phpunit/src/Util/PHP
/opt/suitecrm-7/php
/opt/suitecrm-7/php/bin/php
/opt/suitecrm-7/php/lib/php
/opt/suitecrm-7/php/include/php
/opt/suitecrm-7/php/php
/opt/suitecrm-7/php/php/php

Try this command

crontab -e -u daemon

* * * * *     cd /opt/suitecrm-7/apps/suitecrm/htdocs; /opt/suitecrm-7/php/bin/php -f cron.php > /dev/null 2>&1

And if you really have a timezone problem, set it in php.ini. The path you need to use to edit the correct php.ini file (there can be more than one) is given by

php -i | grep php.ini

THANKS :slight_smile: now the scheduler works :slight_smile:

Last Successful Run: 29-01-2020 20:27

But there is no case created

scheduler : Check Inbound Mailboxes running
but last run was yesterday, it stopped suddenly, but status is running

all other scheduler jobs are running and logging every minute

I do not understand what happened since yesterday

In the Check Inbound Mailboxes detail view, below, in the job log, does it show as running for a long time? Maybe it’s hanging for some reason, but I’m not sure why.

If you can restart it and check your logs, there might some clues there…

OK, there was a problem with email (imap settings) now the problem with mailbox is solved

after changing the configuration it also creates CASE :slight_smile:
i am very happy

thanks again, I really appreciate your willingness to help me and solve the problem

regards,
Ismet

1 Like