Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Image field types only displaying as text fields in Studio

Hi All

I am trying to use an “image” field type in the “Targets” module.

I have added a new image field - with “Image” as its field type.

I have edited the the “Detail View”, added a new row and have dragged the new field into position; saved and deployed with no errors.

When I visit the new target page, the field exists however it is only as a text field. I have no ability to upload a file or paste an image from the clipboard. If I drag an image to the field, it just records its path as text.

I have looked at the User module/field/layouts to check to see I’m doing it right, and as far as I can see, I am.

I have looked through the forums to see if there are any reports of similar behaviour.

Suite CRM is being run on:

SuiteCRM 8.0.1
Ubuntu Server 20.04
Apache 2.4.41
Browsers running on Linux - Firefox and Chrome.

Any ideas?

I have been looking into this a bit more and it seems that other field types have issues as well. Instead of an Image field, I have tried an IFrame as well and that doesn’t even appear on the edit or detail screens.

Have you added the image field also to the Edit view?

Hi @pgr

Yes, the fields are in the Edit view as well.

I’ve always used Image fields in a straight-forward way.

Do you see a “Browse” button on the edit view, next to the text field?

No - that’s the weird thing…no other controls appear. I can see they do on the User module for the profile picture. Using dev tools I can see that there is no other control except for the text input field.

This is all very different from the HTMl that wraps around the Photo field on the Profile page which does work correctly.

This isn’t just an issue for ‘new’ fields created in Studio. If I select the “Photo” field that is a “system” field, not a “Studio” field and add it to the layout, it just renders as a text field - doesn’t offer up a browse button.

ya right. this is problem with image,html,iframe etc fields in all custome modules and some built in modules. and notice that in which module image,html fields shows as text fields in that custom java scripts also not working.

hello sir, Have you got any Solution? please share if you solved.

Hi. Any update on this issue as I have the same problem in the Contacts module. I have added the Photo field to both the detail view and the edit view and the Photo field shows as a text field, not an image field. There are no controls to upload an image.

+1 Can also confirm the Image field does not work on the front end. Can add in studio but just shows like a normal text field on front end in SuiteCRM8. Works fine in 7. Following.

Solved (kind of)… see t his post. Workaround is to change the module back to legacy and the image fields will work. This is a temp solution until image fields are properly coded for SuiteCRM 8.

https://community.suitecrm.com/t/image-field-not-displaying-the-choose-file-button/84713/11

And here…

https://community.suitecrm.com/t/compatibility-mode-in-suitecrm-8/83355/2