Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Image field not displaying the Choose file button

I recently installed SuiteCRM and noticed that it is now a new version. I added an image field in the account s, which I have working fine in a previous version (7.1). When I add the image field on the new version, I am not getting the Choose File button on the account form when entering a new account. Is this a bug in the new version? Please help. Thank you

Welcome to the community @prodiversesolution :wave:

Unfortunately the photo field hasn’t been fully implemented yet on SuiteCRM 8. I can only suggest if you require the image field to currently set the module to compatibility mode so that it uses SuiteCRM 7 rendering for the time being.

There thread can help with setting the compatibility mode for certain modules. Compatibility mode in suitecrm 8? - #2 by samus-aran

What line or parameters do I need to change or add to get the compatibility mode to use SuiteCRM7 rendering?

To route to legacy engine you need to set to false the views of the module that you want to change.

Thanks for your reply, but I don’t understand, in the legacy.module_routing parameters there is no view parameter. Only index, list and record. Where is the view parameter at? Thanks

Those three words are the names of the views in SuiteCRM v8.x

I know that list is the List View, and record is the new record view that joins together both Detail and Edit views of the legacy SuiteCRM. I am not sure what index is, possibly it’s dashlets on the home page, but maybe it’s best to just run a few tests and try to find out.

Thanks for the reply. I change the parameter to false on the Accounts module but it did not make a difference. The image field still did not work. I guess I will just have to deal with it and wait until they implement the image field into this version.

Did you notice the view changing appearance? If you look closely, the old, legacy modules are quite distinct from the new ones. Your field should work if you can actually get the module to go through the legacy view.

No there was no change. I guess I’ll have to wait until they implement it into this version.

OK I have tried this and it does work… here’s some tips:

First of all, if you want it to use the legacy module set it to “false”, it seems counterintuitive as it’s called “legacy module routing” you’d expect it to be the opposite.

ALSO… all the module names in the file are in lower case ie: “accounts” when they are actually “Accounts” in SuiteCRM, so if you have a custom module, you’d expect it to be lower case. You’d be wrong. I have “PLNE_Planes” module and you have to enter it exactly as it is in SuiteCRM custom modules folder.

ALSO… do not “tab” in the file to line up the columns, will not work. Space bar only.