How to enable TinyMCE in Case resolution field?

I’m tinkering with SuiteCRM 7.12.5 and I’m trying to enable TinyMCE in Case resolution field, so the resolution can be edited in WYSIWYG way but I’m unable to do it in upgrade-safe way.

When I edit directly /modules/Cases/vardefs.php and add

'editor' => 'html';

for the resolution field array, TinyMCE gets enabled in case resolution field.

I’ve tried extending resolution field through /custom/modules/Cases/Ext/Vardefs but it doesn’t seem to be picked up. I’ve tried creating custom php file (resolution_editor.php) and adding the line to the vardefs.ext.php but none seemed to work.
The line in the php file, as far as I understand, should look like this:


That’s what I’ve been adding but with no effect. Have I been doing something wrong?

Hey @Dermi,

Was playing with this issue this morning, though via the front end at the bottom of profile where there is a dropdown allowing you to chose between direct HTML, TinyMCE and Mozark however it never seems to change from TinyMCE.

I’ll look at confirming this issue, raising a bug if needed and will link here :+1:

That profile option only affects the Email Templates module. It really should affect other places, most notably the Email Compose screen, but it doesn’t (I had to add that to my Power Replacer add-on, so I could have pure Direct HTML editing in the compose screen).

I wouldn’t spend to much time on this in 7.12, since it is already much better in v8…

1 Like

Well that explains a lot xD Thanks for letting me know!

@Mac-Rae Thanks. It’s not that I can’t change to TinyMCE in case resolution description. by default it’s a simple plain text field and I’m trying to enable HTML editor in there in a upgrade-safe way :slight_smile:

I tried playing with v8 but first I couldn’t get it to install in CentOS and finally managed to get it up and running using Ubuntu Server. And when I finally managed to get it to work it turned out I had a problem with dynamic dropdown lists which weren’t working properly (at least in 8.0.4). Maybe I’ll give it another try, as I’m still just trying to see if I’ll be able to tailor it to my company’s needs.

1 Like

You should create a file containing


in custom/Extension/modules/Cases/Ext/Vardefs
Then, run Repair / Quick Repair.

1 Like

@blqt OK, I’ll try it tomorrow. I see you suggest to create file inside custom/Extension/modules/Cases, while I’ve been adding it to /custom/modules/Cases. Maybe that’s the reason it didn’t work. I’ll see and let you know.

EDIT: Thanks, it worked! I knew I were doing something worng, it turned out the file needed to be placed in /custom/Extension/modules, like you said, not in /custom/modules/, where I’ve been putting it.

1 Like