How to assign inbox group email account to users?

Hey folks! I’m circling back round these issues documenting them today, if you have any more issues with emails please let me know exact info so i can attempt to replicate them. Thanks!


I will try to write down my different issues I had with emails next weekend.

But as I am not working with suitecrm anymore for the last 3 months (new job) I will have to check they are still relevant

Good day to everyone !

1 Like

Hi @Mac-Rae - they are still relevant as detailed above.

Just the other day I spent really quite a couple of hours spread over a couple of days on it trying all sorts of things to get it to work, eventually had to stop.

Hi @Mac-Rae,
yes they are still as described above.
Perhaps the most programmatic way to understand our issue and help us, is to setup a new instance with the demo data.
Then create the two teams east sales und west sales as described in the security group documentation (as example).
Make a real group e-mail account for both sales teams and try to assign them to the users of each team.
If you succeed on this please document the steps (perhaps extend the documentation) you performed.
I’m willing to test this step by step based on your description and let you know, if and where I got stuck.
This is all close to a real starting configuration and I would believe it is helpful for everybody.
With best regards

Hey folks!

So! I managed to get it to work; I will point out that this is not a great setup and definitely needs improvements which I hope we will see with Suite8. I’ll write up proper documentation when I get the chance, however, for now, here’s the walkthrough of how to set up as you wanted.

  • Set up both your teams

  • Make sure all users who are using the group emails have a personal inbound and outbound email (Outbound can be system)

  • Create the 2 group emails, make sure you tick the “Allow users to send emails using the “From” Name and Address as the reply to address” options

  • Go to the user’s accounts as admin and open the emails menu, tick active next to the email account you want them to access.

  • Then in the email folders options hit none, this will display all emails folders this user has access to.
    CTRL+Clicking on an email folder will cause it to be hidden again.
    Hide all folders they don’t need.

  • Log in as the user, and in the emails module, you should see the emails displayed for that folder.

Hopefully, that works for you all, if not let me know and I can break it down further! There appears to be more than just a few issues :laughing: but I’m sure that during the development of Suite8 this system will be replaced or fixed in some manner to make this way more intuitive :+1:

1 Like

Quick edit, the button you need to tick is called this - Allow users to send emails using the “From” Name and Address as the reply to address:

1 Like

Came across this thread while trying to set up multiple group emails, however it seems that group emails and “personal” emails may conflict with each other if they match (auto-importing of emails stops working and thus custom logic hooks may also stop working).

This is just to note that the suggested setup is only a workaround and may not always work correctly.

What do you mean “if they match”? Meaning the Group email and the Personal email are for the same address?

Yes, that’s exactly what I meant :slight_smile:

Frustratingly the problem seems to still exist in some state. I have a reasonably new local install (though data are from an extended period). About is reporting as Version 7.11.18 Sugar Version 6.5.25 (Build 344). For some reason I as a user in security group (Academic) and role (Academic) am able to check group emails, but another security group (Front of House) and role (Front of House) am is not even after using the ‘Rebuilding Folders’ procedure you have. That led me to think it’s an odd permissions setting, BUT to try to chase it down I enabled all modules and selected ‘All’ for all permissions. The users assigned to Front of House still cannot check emails. I created myself as a new user in Front of House and then also added my role as Academic. The new user still CANNOT see any group emails neither before nor after doing the ‘rebuild folders’ procedure. It was just a hunch…hope it helps hunt down the issue.

Handling group emails is a core function of a CRM. Any new insights into this matter?

Sorry but I don’t understand this step. How exactly do I go the the user’s account as admin? Can you please tell me the steps as to what to click to get there? When I am loggedin as an admin, I can click on TOP RIGHT MENU > Profile > all the way to the bottom SETTINGS > click tab MAIL ACCOUNTS, and I see the group accounts and they are checked. When I login as the user and do the same, the group account do show and they are checked. However, when I go to the emails module and click on the top account navigation thingy, I don’t see the group accounts in the popup that shows.

Hi @ Mac-Rae, could you please confirm your recipe is still working?

I’m dealing with this in v7.12.5 but I think it’s not working at all. Your participation in Basic setup with group email will be appreciated.

I could work in a PR to solve this problems but I need to understand the expected behaviour.

Thank you.

Hi, just in case others are still having this issue, I had a similar problem and was able to get it sorted with a workaround. Access to the database and some familiarity with databases is required for this. The problem occurred in version 7.11.10, although the workaround is still fine after subsequent upgrades.

Some of our users were able to access the inbound group mailbox while other users were not. The users with problems could not even see the inbound mailbox and it could not be added for them through email settings. This was noticed after we changed the group mailbox settings to a new email account. It doesn’t look like security settings were the issue. One of our users who couldn’t see the mailbox was in the same security group as another who had no problems.

This resolved the issue for the affected users:

  1. Have a backup before you touch the database.
  2. Grab the unique ID of the inbound mailbox. I found this by going to admin → inbound email → and then click the name of the group mailbox. The ID of the mailbox is at the end of the URL after ‘record=’
  3. grab the unique ID of an affected user. (from admin → user management: click the user’s name and then the user’s ID will again be after the ‘record=’ in the URL
    4)In your SuiteCRM database, find the folders_susbscriptions table and insert a new row:
    -the ID column needs a new uuid
    -the folder ID column needs the inbound group mailbox unique ID
    -the assigned user ID column needs the users’ ID

No idea why this relationship was missing for certain users and present for the others. After adding this relationship where necessary, users had no further issues with accessing the group mailbox.


@Dylan-W thanks, that’s a valuable insight.

Are you a PHP developer? Can you trace the point in the code where that extra row in the DB makes a difference?

All these email configuration issues are really critical to sort out in the CRM… we should make sure the bug gets reported and fixed…

Is this fixed or do we still need to create this relationship manually in the database?

I just installed 7.13.2 last week on PHP 7.4 and MySQL 5.7 on Apache. I’m still having issues with this, as well as an inability to switch between IMAP folders inside of a single email account. Insane. Has nobody (devs) got the solve for this yet?

I can confirm there is still an issue here. 7.12.8. I’ve done a bunch of testing as well. What I’ve found so far…

  1. My folders_subscription is getting populated properly in the DB
  2. An older group email that I added has no issues.
  3. A recent group email I can’t have users see it. (Admin works no problem).
  4. I can add the folder subscriptions by logging in as admin to the user. (However, the popup says “saved” but they are never saved, if I re-open the user, they are gone).
  5. The folder subscriptions are not available for the user when logged in as the user!!!

Not sure where else to look. I’m going to attach a video shortly of the behaviour.

Hey @Mac-Rae MacRae, maybe I’m missing something important here. What do you mean by: " * Set up both your teams"