Google Calendar Sync - No SuiteCRM Calendar Created in Google Calendar

I have enabled the google calendar sync on my suitecrm 7.11.15. I created the API credentials and uploaded the json file. I have authorized my suite user to the domain via google signon. I have enabled the calendar sync. I am still unable to get the sync to work when i build a meeting. I do not see a Suite CRM calendar in google calendar. I see a variety of errors in the suite logs set to debug including:
Unable to find SugarController:: Google Calendar Settings
Cannot find bean file for module: Calendar
Scheduler has the sync running every 5 minutes. I’ll have to check with my hostcompany (hostgator) to see about crontab. But on the surface I think it is working. Any ideas?

Looking at a post from Benjamin.Long, he asked about a job log with Google Calendar Sync, I opened it and Last Successful Run is Never.
CRON does reference the cron.php file.
However I looked at ALL scheduler tasks and all are Last Successful Run is Never.

this should help

Ok, I checked the config.php file and the user is apache.
The Scheduler window says to add mbcadmin to the crontab file.
I use hostgator and don’t have terminal access that I can see.
Do I need to ask them to add mbcadmin as a user to crontab?
Do I need to add mbcadmin in the array for allowed_cron_users?
It currently reads 0 => ‘apache’,
would I add the next line as 1 => ‘mbcadmin’, ?

I also saw a cron discussion on hostgator’s cpanel knowledgebase and it referenced putting the user in front of the job in cron. Would that be apache or would that be mbcadmin? Do I add two lines and see what happens?

Scratch all that. I left apache in config.php and found this reference of an incorrect syntax of the cron job:

SuiteCRm built it differently than what my host listed in some apache cron job notes, It is similar to the link in the above URL.
Solution: cd path to suitecrm ; /opt/cpanel/ea-php phpversion /root/usr/bin/php -f cron.php > /dev/null 2>&1

This is mine:
cd /home1/user/public_html/website/SuiteCRM; /opt/cpanel/ea-php72/root/usr/bin/php -f cron.php > /dev/null 2>&1

I now have ALL the scheduler tasks running!

I now have a SuiteCRM calendar in Google!!!
And I have calendar entries in both google and suitecrm! Whew - that was a lot of work.
I would recommend modifying the google sync instructions to include a CRON job discussion and reference alternative cron job entries and to verify with the hosting company:

Now I need to figure why the entries are 4 hours off the correct time.

Time zone in the SuiteCRM google calendar settings needed to be set to my timezone - by default they are UTC 0.

also, the timezone of the user in suite crm needs to be accurate