Getting a message "error occured while retreiving records" on save of every object changes

Brand new install by Sofoculus script - a couple of hiccups but installed fine.
Uploaded the Contacts and Accounts using the template.
When editing an object - Contact or Account - and changing some data and hitting - SAVE - I’m getting the spinning logo and the error “Error occurred while retrieving records”.
SuiteCRM v8 - path 8.2.2
PHP - version 8
Running on a shared server - access to root by the host company.
I tried a few things but I am not a coder - and cannot get this to go away.
Has anybody run into this before - and how did you resolve the issue?
I like the new version and would like to stick with it instead of going back to SuiteCRM 7.
The error goes away after running REFRESH on the browser… Unsustainable long term :slight_smile:

Hi @mc_crm_444

This error is caused by an invalid token, this has been patched in the last release 8.2.3
Personally, the registration is done correctly now but the error message persists

Realease 8.2.3

Issue GitHub - Invalid CSRF token

1 Like

Getting this on a fresh 8.3.0 install too, but when trying to log in.

The first time I attempt to login with the admin user, I get “invalid credentials”. If I try with the exact same credentials again, I get "error occured while retreiving records”.

I re-start PHP, clear the SuiteCRM cache, re-start Apache, but the exact same pattern prevails. Right before it shows the last error message, it gives me a glimpse of something that could be a dashboard or a menu, but then it kicks back to the login form with the error message.

I’ve tried installing both via the “GUI install” and via bin/console, both methods “work” and completes successfully, but then I can’t login.

This errors occurs on V8.3.0 and the error message in the logs points to Invalid CSRF Token. The first login attempt says invalid credentials, the second login attempt says error occurred while retrieving records then the third attempt works to login. The Suitecrm Logs generally show working GETs but there are regular and consistent blank requests with 408 codes during this process.

Ubuntu 20.04 LTS, PHP 7.4.

1 Like

My SuiteCRM details:
SuiteCRM8.3.0 on Ubuntu 22.04 and php8.0
I’ve the same error. The third login attempt works.
This happens when I login via the website, and the domain name.
When I login locally with the local ip address it works fine.
Still investigating this error.

I updated my test V8.3.0 site to PHP 8.0 to match the configuration matrix requirements and I get the same issue of failed logins and three tries to get logged in. Logs show consistent blank requests with 408 codes during this login process. If I logout it does not do this. If I leave it logged in then eventually the login expires and the triple login is required.

Was this finally resolved?
I have a fresh installation of 8.3. After every few seconds, there is a “Error occurred while retrieving records” message on the screen. The login does not seem to expire, but the message keep appearing, nothing in the logs that points to the error.

I changed my php session.gc_maxlifetime variable from 1440 seconds to 90000 seconds so it would not collect garbage until the next day. So far, the logouts and problems above have not occurred same day. To see which php.ini is being used, I loaded phpinfo in the legacy directory, executed it and found the php.ini to adjust. Delete the phpinfo once you are done.


A phpinfo is provided for you at Admin / Diagnostics / phpinfo.

Could be better, but is quite useful as it is.

I agree that tool to get phpinfo works well. thanks.

Hi @mc_crm_444,

Enable “Alerts” module and set correct permissions to users for that module.

1 Like

i was facing this type of error in user account.
after enable alert error gone.thanks.

Sorry for being a bit dim here but where do you enable the Alerts module ?

Is this a PHP element or something else.

user and authentication > role management > alert

OK thank you.will do this and see how it goes.

The issue for us must be a little deeeper as this is happening to 2 admin users who are not linked to any roles or security groups at all.

The standard users, who are assigned roles and are members of security groups are not having any problem as far as I know.

It is strange that it is only their first login each day that does this. Once they have logged in, refreshed and logged out successfully, all further sessions are absolutely fine.

Thank you anyway.

Glad that it is working for you. So you’re saying that we need to assign every user to some role/s in the CRM?

Not neccesarily. What i am saying is that the users who are assigned to roles and security grops arent getting the problem. Two admins are and as policy, we dont assign them to a specific role. I will set up a new admin user and try without a role assigned and then with one.

This may give us an indication of the issue. However we have other higher priority work at the moment so this will be a few days at least.

Thanks for your help though.

Sounds great! let us know once you tested it out :upside_down_face:

Does anyone know how this issue was resolved. I too have a fresh install of SuiteCRM. I’m trying to add target records, and I keep getting this error and a bunch of others and the info isn’t saved.

However, I can create Accounts and contacts with no problems.

I get the above errors upon login, after trying to save information manually. I’m not logged in with the system up for an extended period of time for it to time out.

So I’m at a loss.

If this system is going to be this difficult, I’m not going to bother to use it.

The whole point is for me to be able to concentrate on marketing campaigns and follow-up, not troubleshooting something that shouldn’t be broke.