Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Email Error: Not authorized to use Outbound Account "system"

Hi,
I’m getting this error when sending email from personal account:
[SECURITY] Email Error: Not authorized to use Outbound Account “system”
SuiteCRM Version 8.1.2
All tests worked.
When I go to email configuration for that user I see this (please note system account is in the 1st line and couldn’t be deleted):
image

Please help,
Thank you!

I understand that there is a workaround that might be used in some cases from here:

“There’s a check box in Admin / Email settings, to indicate that the system email address can be used by individual users. You need to check that.” This is not good as email is coming from whatever is entered for system account, instead of person that is sending it.

Or in case the only one user of the CRM that user’s email could be entered as a system’s outbound.

But this is still a bug in the CRM, that needs to be addressed for the proper emails sending.

Thank you!

Where are you trying to send the email from? Is it a Campaign? Or perhaps the “Compose window”?

If it’s the Compose window, make sure you’re selecting the correct account in the “From” dropdown.

Thank you pgr!
I go to Contacts > View Contacts then Email Icon for the contact that brings Compose Email window. And there in the From I have only 2 lines: 1st one is empty and 2nd is SuiteCRM for system’s outbound account.
Although I do have tested personal account in Outbound Email Accounts:

image

In that dialog box on the first screenshot you posted in this thread, there are two areas with account definitions, one on top and one below. Make sure you have SMTP settings in both, even in the Inbound definitions, if you can find a space to type them in.

System doesn’t have settings for Inbound as it is send only account, and the personal one has IMAP working. So yes, all settings are there and tested/working.

You need to get to a point where these :point_up: are not your only options. The email config screens are so buggy that I sometimes go and fix things directly in the database - tables inbound_email and outbound_email.

Good luck!

I looked into both tables in the database and there is nothing to fix in there. So it is something with the code then. Thank you!

If you are a technical person, I recommend also peeking inside the stored_options fields in those tables. Just put those encoded values here to see the contents:

https://www.base64decode.org/

Some of the “from name” fields are stored in there. If you need to change something, do it, then run it through the encoder and put it back in the DB.

Hi pgr,
And thank you so much for your help. 1st I looked into the stored options and decided to enter something in those 3 empty fields:
s:9:“from_name”;s:0:"";s:9:“from_addr”;s:0:"";s:13:“reply_to_addr”;s:0:"";
so I changed all to s:2:“x1”; and the empty line in the From (Compose Email window) became x1.
Then I went to personal inbound settings and there at the bottom was an option to choose outbound account that I don’t remember seeing before. Or maybe I didn’t pay attention to it as it was “Outgoing SMTP Mail Server: system - smtp.zoho.com” and smtp.zoho.com is a correct value for the SMTP server.
After changing it to: “personal - smtp.zoho.com” I can now send emails from the personal account.

1 Like