Can't send email

I have Version 7.9.1 of Suite CRM. I think it might a problem with it or haven’t installed it properly. The problem is when I want to send mail from my user account. When user write a mail, and click on send Suite displays information:contact Your Administrator…etc. When I log as an admin I click on admin->User anagement->Edit. Then I click Send Test Mail and I’m give an info: The administator has not yet configured the default outbound account. Unable to send test email.. Where do I have to set default outbound account? I think I did it in Admin->Email Settings but it seems it doesn’t work. Can You help me to get it sorted out?

Hi!

Version 7.9 had a new Email module, and there were bugs in need of fixing in the subsequent releases. We are now on version 7.9.10, so you should start by upgrading and then retrying your issue.

As always, make sure you have a full backup (files + database) before upgrading.

I upgraded to Version 7.9.10 but it still doesn’t send emails. :sick: I go to edit user, and to mail settings then to Mail Accounts ->Outgoing SMTP Servers. I’m adding account details,but after clicking done this server doesn’t appear in Smtp list window. In log I can see: If you are on user edit view and want to apply the email settings for the selected user,
add user to request on user edit view: [emailUIAction:saveOutbound]

What is happening?

I’m sorry, I don’t understand exactly what you’re trying to do. If you can please post some screenshots or explain step-by-step, that would help.

Also please make sure you copy-paste any error messages exactly as they are written (so I can search the code for them).

thanks

First thing is that I want to send mails from any user in Suite CRM. To do it, I have to set smtp account because I get info: Error Sending Email. Please contact your administrator for assistance.

So I log as an admin and go to: Admin->User Management and I choose my user to edit his settings (picture 1.png). Then I go to SMTP settings (fig. 2.png), click ADD and then to settings (3.png). When I click Done, I get no changes which should appear on SMT settings (fig.4.png). In /var/log/suitecrm.log I get only this:
If you are on user edit view and want to apply the email settings for the selected user, add user to request on user edit view: [emailUIAction:saveOutbound]

Can you try rebuilding the “system” account to make sure it has a “From name” and “From address”? There was a bug fix recently that affected these fields.

Tell me how it goes, if it doesn’t work, we’ll try something else.

Where can I rebuild this account?

I think You didn’t understand what I wrote. I meant, that I can’t add any new SMTP Outgoing settings in this box (picture nr 2.png). Look at this picture, when I click ADD I can fill all forms, but when I click Done, nothing is added and only system account is present.

I can also add, that after clicking on ADD button I get message in suitecrm.log:
If you are on user edit view and want to apply the email settings for the selected user, add user to request on user edit view: [emailUIAction:saveOutbound]

You can edit the system account from Admin / Outbound Email Accounts.

I told you to go there because of that message showing in one of your screenshots:

I know this is not entirely related to what you’re trying to do, which is to set up a user account. And I know that other message saying “Data error” on the user account is not a good sign at all. But my hope is that by fixing one problem, maybe the other one will fall into place.

Please try fixing the system account and tell me how it goes.

Ok, I’ve set system account as You mentioned (picture 1). But I still can’t send mail from user account. When I want to compose new mail and want to send mail I get this (Picture 2):

That “data error” is definitely a sign of something very wrong.

I’m not sure if this will help in this case, but if you can try this SMTP debugging procedure here, you might find out what is breaking the configuration:

https://suitecrm.com/suitecrm/forum/suitecrm-7-0-discussion/16507-mail-stopped-working-error-smtp-connect-failed#55682

(warning; don’t post the logs form that online, they will contain your password)

Ok, I did everything You wrote in this link…but there’s nothing usable in suitecrm.log. And I can’t find any PHPMailer word, and nothing what could be usable. I might doing something wrong,or it might be wrong log level? I set log to Debug in Logger Settings…

It might be that the code simply is not reaching that point… that’s why it’s not logging anything.

Check both logs for any FATAL or ERROR messages;: suitecrm.log and php_errors.log

If you’re a developer, I suggest stepping through the code with a XDEBUG to see where it’s goign wrong.

If not, if you can make some backups of the files and database, I would suggest more drastic measures - go into the database with phpMyAdmin and clear the outbound accounts table rows that belong to that user, if any. There might be something corrupt about your settings…

No…it doesn’t work either. I removed all details from table outbound mail. Even in logs, I can’t see anything what can help me in finding solution. No WARN, no FATAL in my logs :frowning:

This is really a hard case to crack…

Please tell me if you see anything in your browser’s developer console at the time when you get that “data error” on the inbound list, and also at the time of saving Outbound settings.

Another idea: to test with my code, did you try to send email from that Email module? It is meant to be called from the Admin / Outbound email accounts, test settings button.

I’ve reinstalled suite CRM, and set everything again. Now, when I want to send mail from one account I get this in log:

User xxx attempted to send an email using incorrect email account settings in which they do not have access to.

Why is it happening? I have set smtp account for this user.

Which version have you reinstalled? 7.9.11?

While you’re at it, please tell me your versions of OS, PHP, web server and database. I really want to get to the bottom of this.

For the email problem, check Admin / Outbound accounts. If you have a system account with that same email, and you haven’t ticked the checkbox to “allow other users”, you would get this problem.

I now have a test system that is also showing the “data error” message. I’ll try to debug it tomorrow when I have the time…

I’ve installed latest version, OS: Debian 8.7. MySql, PHP5. I’ve just put a tick on “Allow users to use this account” and I was able to send email, but from this main system account. I have to do it from my account.

I’m sorry, if this sounds annoying, but which latest, and which PHP 5? And you didn’t say which Web server.

There is a latest LTS, a latest 7.9, and a latest 7.10 RC. PHP minimum is 5.5 for the first two of these, but 5.5.9 for 7.10 RC.

I’m just trying to make sure no small detail is betraying us in this ordeal.

If you can now use my SMTP debugging code, you should get a clear view of what is going wrong with the personal email configuration. I am inches away from including that code in the main product to be able to view these full SMTP logs inside the app, without need for dirty hacks. It would be nice to know if this code helps you track down the problem…