Button Next dissapeared from Upgrade Wizard

I have installed the additional patch in 7.11.14 upgrade successfully.

Then went to the Upgrade Wizard, run the system check, everything was fine… but I can not find the NEXT button to proceed to the following step

Any clue?

Already tried closing session and logging again, quick repair, opening from different browsers and devices… but it does not show up.


I’ve found a few places where users have described a similar situation on similar SuiteCRM versions, where applying the patch causes the “Next” button to disappear:

Do you see any errors in either the SuiteCRM.log, upgradeWizard.log or apache logs?

Also, would you be able to re-set the file/folder permissions, and see if that resolves the issue?

If you find that you’re having similar issues as the above posts, it would definitely be worth adding your two cents onto the github issue, to further raise awareness

If re-setting permissions doesn’t seem to resolve the issue, It seems users in the above posts have had success with rolling back to a previous version, and performing the upgrade without the patch.

Or, if a server rollback is not possible, manually replacing the patched files with the previous versions of the files.
(Which could be grabbed either from the SuiteCRM github, or by downloading a version of SuiteCRM that the files previously came from)

Based on another thread, I have asigned the following folder permissions, but I am afraid it is still not working

sudo chmod -R 755

sudo chmod -R 775 cache custom modules themes data upload config_override.php


Those should largely be the correct ones, what’s normally recommended is:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chown -R www-data:www-data .
(replacing www-data with whatever your web server user is)

I’d suggest updating the owner of the files too, if you hadn’t already (the chown command)

If that still doesn’t work, for the time being, perhaps rolling back or replacing the patched files would be worth a try?