Blank Admin Page

Hi There

Having a problem with my admin page as its blank.

Before blank, i tried adding module name in to the “pdf_template_type_dom” in order to get the PDF template generated.

Screen Shot Of the blank page attached…

Please advise

Hi Cliff,

What is your environment/server set up?

This could be permissions related. There may also be errors in the sugarcrm.log file in the SuiteCRM directory.

If not, you may need to turn on error reporting(we can advise how to do this) to see if there is a fatal error that’s not being outputted.

Thanks,

Will.

Ahh so thats what a blank page looks like :stuck_out_tongue:

You have caused a fatal error somewhere, Turn on error reporting as above.

Thanks Will

I’ll do that and come back on this.

Regards

Cliff!!

Hi Will

we are using ubuntu linux

Regards

Cliff

Hi Cliff,

We would recommend setting the following permissions:

sudo chown -R www-data:www-data .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php

You may need to turn on error reporting to debug the issue, to do this simply set ini_set(‘display_errors’,1); at the start of the index.php file. We would advise removing this as soon as it is no longer required, to prevent errors outputting throughout the CRM.

Thanks,

Will.

1 Like

Hi Will,

Tried making the below changes, still the admin panel display is blank.

Hi Cliff,

Did you make the change to add error reporting to the index.php file of SuiteCRM to see if any errors are outputted?

Errors may also need enabled in your php.ini file.

Thanks,

Will.

I had the same issue when I moved Suite to a new server. On the new server I needed to install PHP’s mbstring module.
That fixed the issue.

Hi Will,

I have a somewhat similar problem, but not alone for the admin page, but also for the emails page and create/edit email template ( maybe some more).
This all works fine when I work in the English version, but the issue starts when I login in the Dutch version.

Error reporting on the admin page and the emails page and email template gives:
Parse error: syntax error, unexpected ‘Van’ (T_STRING), expecting ‘)’ in /var/www/html/suitest/modules/InboundEmail/language/nl_NL.lang.php on line 98

Regards Jaap

I fixed it by adjusting line 98

Thank you very much
After bashing my head around, this solved all my problems

Somi