Any problems or issues? Let me know!

Hi folks.

If you’ve had a chance to try SuiteCRM Analytics then i’d love to hear your feedback or any issues you have run into! Im more than happy to answer any questions no matter how simple or complex they might be.

Im really looking forward to hearing from you!

1 Like

I installed your zips yesterday in a virtual machine. Tutorial was fine and understandable, I had just one issue during the installation and I’d like to share my fix:

While running


the script stopped with an error like “couldn’t create all tables, check user privileges”. The provided user (adminer) was fine, but I found an additional error message in the logs (“Specified key was too long; max key length is 767 bytes”).

I’ve added these db settings:

innodb_file_format        = barracuda
innodb_large_prefix       = on
innodb_default_row_format = dynamic

After restarting the database and running the .sh-file again, everything went smoothly (thanks for the nice tutorial!).

I used a turnkey-linux for this test installation. The used database:

mysql -v
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 2
Server version: 10.1.37-MariaDB-0+deb9u1 Debian 9.6

I’ve never used pentaho before, I guess most users would like to have a summary as well on how to

  • create your first own report
  • restart the ETL (and maybe how to include custom modules/fields/relations)

Great feedback thank you! We will look into this issue and try to make future installations a little smoother.

As for documentation and tutorials, thats the next thing we will be working on and version 2 of the solution which will include more reports / dashboards and templates to help you get started.

The first set of tutorials we plan to work on are geared around building reports to help you guys create your own interesting solutions!

Video Tutorials would be more Helpful than Written Docs. Just a thought.

@ivyis: if we can help you with (german) translations, please contact us!

i tried to establish the suitecrm data integration and analytics in my local system, i tried to do it in windows machine, and i use cygwin to execute bash commands.
the suitecrm analytics web application is established, but i couldnt establish connection to mysql database when i trying to set up suitecrm data integration . i use mysql in wamp for database.

i copied the data integration and analytics package in C:\wamp64\www folder.

please guide me through

Did you run the setup-suitecrm-data-integration script and you are getting a message saying that it failed to connect to your database?

Can you send me the output of the setup script please?

SHANKAR PC@DESKTOP-4KG90QT /cygdrive/c/wamp64/www/suitecrm-data-integration-server
$ ./

We are about to setup SuiteCRM Analytics Data Integration
Make sure you have configured the correctly

*** IMPORTANT! *** Running this setup will discard any previous installations!

Have you configured [y/N] y


Checking database Connections…

We could not establish a connection to the SuiteCRM database!
Please check the JDBC connection properties and run setup again.

Installation is complete!

I assume you have configured the correctly with SuiteCRM database details. Can you test those connection details and make sure they are correct?

please check the attachment…for connection status

the db name , username and password is given right in and i use mysql workbench as UI for mysql. if you need any more information to help me please ask me

Can you look at the logs/check-database-connections.log file please? That should give us more information of any issues

what happens if you enter

javac -version

into your command line?

the log;
Overriding KETTLE default JVM mem size: 1024
DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files\RedHat\java-1.8.0-openjdk-
DEBUG: _PENTAHO_JAVA=C:\Program Files\RedHat\java-1.8.0-openjdk-\bin\javaw.exe

C:\wamp64\www\suitecrm-data-integration-server\client>start “Spoon” “C:\Program Files\RedHat\java-1.8.0-openjdk-\bin\javaw.exe” “-Xms1024m” “-Xmx2048m” “-XX:MaxPermSize=256m” “-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2” “-Djava.library.path=libswt\win64” “-DKETTLE_HOME=/cygdrive/c/wamp64/www/suitecrm-data-integration-server/configuration/” “-DKETTLE_REPOSITORY=” “-DKETTLE_USER=” “-DKETTLE_PASSWORD=” “-DKETTLE_PLUGIN_PACKAGES=” “-DKETTLE_LOG_SIZE_LIMIT=” “-DKETTLE_JNDI_ROOT=/cygdrive/c/wamp64/www/suitecrm-data-integration-server/configuration/simple-jndi/” -jar launcher\pentaho-application-launcher- -lib …\libswt\win64

the command :

$ javac -version
javac 1.8.0_222-4-redhat

Hi @ivyis,

please take a look on the log which i sent. and also is it possible to use LDAP and SSO in this standalone project.

If thats all you are getting out of the log then it looks to me like the data integration engine isn’t starting up. These could be for many reasons but I suspect that its because you are using Windows / cygwin and the setup script has been written and tested on linux.

What I can do is create a setup that will work for Windows for the next release which should be in the next week or so and update the documentation to reflect a windows installation.

If you can hold on a little until the next version I will try and get this fixed.

As far as hooking up to LDAP, it is possible and you can refer to the Pentaho documentation on how to do this here.

Hope that helps!

1 Like

will wait for you and thank you so much for your king gesture. really much appreciated.

Hi, I installed data integration and web analytics in linux environment, the data Integration successfully created tables, but in the web analytics, the tomcat server is started , the application didnt start.please take a look on the attached image.

Hi Ivyis,

i deployed and started both data integration and web analytics in linux system, but the web analytics web app is not starting, could you please help me on this?

Can you look at the log file in suitecrm-analytics/tomcat/logs/ called catalina.out? If there is no obvious error you can spot in that log then send me a copy so I can take a look