Add users to Inbound Email Group

Hi, I am using Version 7.11.13 of SuiteCRM, and I am trying to add Users to my newly created Inbound Email Account. I’ve created the inbound email account from Admin->Inbound Email.

When I go to the user profile of my admin account that created the Inbound Email Account and click “Settings” under “Email Settings” I can see my Inbound Email Account under “Folder Management”. From this account I can view emails from the email module.

However, when I edit the account of another user, and click “Settings” under “Email Settings” I do not see the new Inbound Email account under “Folder Management”. From this account I can not view emails from the email module.

I would like to assign access to my group Inbound Email Account to specific users. Is this possible? Thank you.

We have the same issue.

In our case we’re doing a migration from SugarCRM 6.5.11 to SuiteCRM 7.10.25. But I’ve also tried (and failed) on a clean 7.10.25 installation

In both cases I can successfully create an inbound group email box, which the creating admin can see, but no one else. It doesn’t show on the Mail Accounts tab in the user’s profile, so doesn’t show in the list of folders on the General tab, or in the View Mail folder selector.

Note to recreate and confirm the above in my migrated instance I deleted all existing inbound email accounts. However I’m pretty sure that prior to deleting them, a migrated inbound group mailbox was visible to multiple users. But things started going wrong when I added a second inbound mailbox, so I deleted them all to start over.

Is there something you have to do to make these visible to other users? We’re not knowingly using any security groups / roles.

As a follow-on, in a related observation (and something that’s changed since yesterday) the mailboxes shown on the Emails screen for the creating admin user is wrong. On this system there is currently only one inbound account - a group account. But clicking on the mailbox (or folder?) selector there are three shown:

This is completely wrong because there’s only one in the database’s inbound_email table . I also did a quick repair and the two email related repairs… I have seen similar issues on other instances. The Admin Inbound Email screen only shows one, as does the the Mail Accounts tab on the user’s profile.

Hey folks, definitely still a few bugs surrounding emails module ATM that we are looking into.

To allow any non admin user to see group inboxes you must go to there profile via user management, press on mail setting at the bottom of the first page, then click on the mailbox to subscribe to it. Please note that a few bug fixed in the most recent patch allows this to work, so please make sure you are using that patch before saying this specific but don’t work right :stuck_out_tongue::+1: please note that the specific group inbox and system outbound must have the “Users can send as themselves” options enabled for the folders to display.

Thanks for the helpful reply.

Please note that a few bug fixed in the most recent patch allows this to work, so please make sure you are using that patch before saying this specific but don’t work right

Understood. The email processing on our previous Sugar installation “left a lot to be desired”! This does seem to offer improvements and great promise. Note I’m on the LTS thread 7.10.25 - are there any newer patches I should be applying? If so pointers would be welcome.

please note that the specific group inbox and system outbound must have the “Users can send as themselves” options enabled for the folders to display.

I should point out that the text for that inbound email option is not very logical because it suggests it is controlling a SEND ability not a READ ability. In our case it’s definitely a read-only / receive-only email box / address.

Selecting that option did indeed work on my migrated instance but not on my clean instance - go figure! On my clean instance the group account now shows on my non-admin’s Mail Accounts profile (it didn’t before), and is selected:

image

But it still doesn’t show up in the account / folder selector on the emails panel

Note when investigating this just now on my clean instance I did notice another problem. If I deselect the group account, and click DONE to close the popup and then re-click to display the profile and open the Mail Accounts popup again - the group account shows as selected. That has to be wrong.

As a follow-on, in a related observation the mailboxes shown on the Emails screen for the creating admin user is wrong.

Looking at the underlying database and some of the queries being generated, I believe that this is at least partly because the folders related to the deleted mailboxes are not marked as deleted in the database. How is this supposed to work? I would think that when mailboxes are marked as deleted, any associated folders should also be marked as deleted. Further, given there is no logical delete capability for folder subscriptions, I would presume that folder subscription records would be physically deleted only when the logically deleted mailbox/folder records are physically deleted - ie through a Prune Database operation. If I know for sure how it’s supposed to work, I can go in and fix the database manually.