7.8.31 update wizard broken - no next button after patch

In following some of the previous tips and tricks on these forums on how to upgrade 7.8.31 to the 7.10 LTS, it suggests you should install the Module for SuiteCRM_Upgrade_Patch.zip first, then run your upgrade wizard… only problem, after I install the patch, the wizard is now missing the “NEXT” button after the scan is complete.

Any ideas how I get past this to get to complete the upgrade?

Previously, i was getting the blank/white screen after “commit” step in the upgrade wizard. I’ve since restored to a snapshot and then went the upgrade-patch route with the above results.


I’ve found a few older threads with a similar issue:

General suggestions appear to be:

Resetting FIle/Folder Permissions, ie:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chown -R www-data:www-data .
(replacing www-data with whatever your web server user is)

Or, if that fails, Some users have had success when attempting the Upgrade from 7.8.31 -> 7.10 LTS
However, they are rolling back and doing so without the Upgrade_patch installed

Do you have any success with either of these?

If not, please let us know, and I’ll set it up locally and give it a go

Ya, I tried the forcing/updating the permissions as well, and that didn’t change anything. I then overwrote the modules/UpgradeWizard/


back to there original 7.8.31 version (essentially backing out the suitecrm_upgrade_patch). Then re-ran the upgrade wizard, and I get the next button, then proceed, and stops at the white page, and see the following -

In the upgradeWizard.log I see:

Thu, 03 Dec 2020 17:33:38 +0000 [UpgradeWizard] - setting session variables…
Thu, 03 Dec 2020 17:33:38 +0000 [UpgradeWizard] - [At commit.php]
Thu, 03 Dec 2020 17:33:38 +0000 [UpgradeWizard] - Setting error_reporting() to E_ERROR while running upgrade

Both paths for me, either via the Suitecrm Upgrade Patch, or via the original, resulting in a missing next button or blank page, both don’t work for me.

Thank you @John for your efforts and input, its appreciated.

Can you also please give some details about your system?

Is this Windows? Which PHP version?

Ubuntu 18.04
PHP 7.3.14-5 and Apache
MSSQL database on a Windows server

I’ve previously tried to clone this environment, and migrated the database to MySQL, but still couldn’t run the upgraded wizard, resulted in the same issues.

I am convinced that the problem is with the PHP function that returns file permissions, it doesn’t seem to work well on Windows. It is not affected by the DB.

Only the DB is on MSSQL which is on a windows host, but SuiteCRM is on Ubuntu. I hate PHP on windows for just that sort of reason… I find weird stuff, so I stick to Linux now for all my PHP apps.

1 Like

Ah ok

that totally ruins my theory, though :frowning:

I’ve seen many people complain about this but I was never able to reproduce locally. Somebody really needs to dive into this one with a debugger, otherwise we won’t understand what’s happening, I’m afraid

I’m happy to deep dive, I just need some direction or items to look for.

This is the apache error log, for the blank page (which is a server error 500) after “next”:

[Mon Dec 07 17:29:10.975378 2020] [php7:error] [pid 16530] [client] PHP Fatal error: Uncaught Error: Call to undefined method EmailAddress::getSendConfirmOptInEmailActionLinkDefs() in /var/www/html/cache/upgrades/temp/72XR4y/SuiteCRM-Upgrade-7.8.x-to-7.10.29/modules/Prospects/metadata/detailviewdefs.php:51\nStack trace:\n#0 /var/www/html/modules/UpgradeWizard/SugarMerge/EditViewMerge.php(719): require()\n#1 /var/www/html/modules/UpgradeWizard/SugarMerge/EditViewMerge.php(771): EditViewMerge->loadData('Prospects', 'modules/Prospec...', '/var/www/html/c...', 'custom/modules/...')\n#2 /var/www/html/modules/UpgradeWizard/SugarMerge/SugarMerge.php(217): EditViewMerge->merge('Prospects', 'modules/Prospec...', '/var/www/html/c...', 'custom/modules/...', true)\n#3 /var/www/html/modules/UpgradeWizard/SugarMerge/SugarMerge.php(185): SugarMerge->mergeFile('Prospects', 'detailviewdefs....', true, true)\n#4 /var/www/html/modules/UpgradeWizard/SugarMerge/SugarMerge.php(153): SugarMerge->mergeModule('Prospects', true, true, true)\n#5 /var/www/html/modules/UpgradeWizard/commit.php(274): SugarMerge->mergeAll(true, t in /var/www/html/cache/upgrades/temp/72XR4y/SuiteCRM-Upgrade-7.8.x-to-7.10.29/modules/Prospects/metadata/detailviewdefs.php on line 51, referer: https://suitecrm.isoflex.com/index.php

It’s back-end (PHP), each step of the wizard uses one of these files here

–> https://github.com/salesagility/SuiteCRM/tree/master/modules/UpgradeWizard

The files are ‘preflight’, ‘commit’, ‘end’, ‘cancel’, I think

This will probably lead you into this function here:

The check files function completes (if I DON’T do the SuiteCRM_Upgrade_Patch.zip update module), And the Server Error 500/Blank pages is the result after I “commit” in the wizard - after the file checks.

Just before the blank page/server error the upgradeWizard.log shows:

Mon, 07 Dec 2020 17:29:10 +0000 [UpgradeWizard] - Backing up file: /var/www/html/Zend/Oauth/Config/ConfigInterface.php Mon, 07 Dec 2020 17:29:10 +0000 [UpgradeWizard] - file backup done. Mon, 07 Dec 2020 17:29:10 +0000 [UpgradeWizard] - Running pre_install()... Mon, 07 Dec 2020 17:29:10 +0000 [UpgradeWizard] - pre_install() done.

Nothing more in the log after that.

In commit.php there’s a variable called $showNext, have you checked that?

It depends on another one called $stop
Which depends on another one called $errors (sigh :roll_eyes:)

This one is harder to track - it gets changed in many places. Should be easy to track if you’re using a debugger, though

I’m still stuck on this.

Not sure where to debug or how really, I’m not a developer, but I learn fast. How would I go about doing that for this type of situation.

I’m sorry, but if you are not a developer I don’t think you’ll be able to achieve anything here, it’s not a very simple situation to diagnose and solve.

I think (not sure though) there is an issue for this already open on GitHub, maybe you can track that and see if anybody works on it and a solution becomes available.

I’ll add my 3 cents to this so that somebody doesn’t feel that this is an isolated issue; my “Next” button is also missing.

I’m running version 7.11.13 on my own server on Fedora with PHP 7.4.13

PHP 7.4 is not supported, and it is known that SuiteCRM breaks in several places with it…

I’ll take my chances with PHP 7.4 as it’s worked without fail thus far.

Attributing the problem to the use of this php version is, in my opinion, a bit short sighted and conveniently passes the buck. Particularly since this “Next” button issue has been on-going for awhile. Furthermore, other than not being able to upgrade yet again, the program seemingly works flawlessly with PHP 7.4.

I did not attribute the problem to PHP 7.4. I merely pointed out that by using PHP 7.4 you’re opening the door to many unknowns. Which is the wrong way to diagnose an issue - potential causes of trouble need to be narrowed down, not opened up.

And you really shouldn’t assume SuiteCRM works flawlessly with PHP 7.4, that is simply not true. I’ve seen several different issues, and more surely lurk in those 1,000,000+ lines of code.

I’ve spent many hours on this issue and it’s not trivial. Unfortunately I’ve never debugged a system exhibiting the problem, that would surely be more profitable. But my test systems don’t get this problem… :man_shrugging:

Thanks for your attention to this mysterious and evasive issue, @pgr . It’s appreciated!

1 Like