"You have been logged out because your session has expired."

If your provider changes your ip often this can happen. Try adding this to your config.php or config_override.php:

$sugar_config['verify_client_ip'] = false;


I took the time to check the config.php file. PGR wrote (and other agreed) that I need to check the .htaccess file for this:
echo ini_get(“session.save_path”);

There is nothing like that in my .htaccess file.

I need to add this?

As well, the idea of running out of disk space? Not an issue.



I didn’t write anything about .htaccess files. That’s the last thing to check for permissions problems, not the first.

That echo command is for you to find out which path is your effective session path. Then you go and use chmod/chown to fix permissions on it, so that the web server can write to it.

What is this line for?

$sugar_config[‘verify_client_ip’] = false;

I would like t to know what I am adding:)

I also realsied, again, that my suitecrm works in XChrome, but NOT in Firefox./ Wierd.
Ideas on that?


Leave the Firefox issue for another thread, please.

The $sugar_config fix would apply only if your problem was occasional (when your ISP changes your IP address), but not if it’s a problem that happens every time you access the log in screen.

Start by making sure you can write to the session save path.

You are right, it was not .htaccess. It if for config.php. I looked there to, and no echo command.

AS for the echo command, do I copy paste the text:
echo ini_get(“session.save_path”);

Where in the config.php file tdo I put it? Beginning end, anywehre?



No, you didn’t read that post carefully enough. It’s not for .htaccess, and it’s not for php.ini.

What is said was “check your php.ini for a session.save_path setting, if you don’t find one, make a new php file with that echo command and call it from the browser”.


Thanks for the explanation. I am not a programmer by trade. I am learning as I go along:(

I added the line to a new php file as you suggested calling it test.php

But, all it does is display the text that I put in it.

I literally put the line fo text n the file. Nothing ele.

If there is other text I need to add to make it a php file, I am not a programmer to know:(

Thanks for guidance.


Yes, you need to add a little extra stuff in there:

       echo ini_get("session.save_path");

or if you prefer you can print ALL settings at once with



The reply that I have is:


Just to let you know, in my set ups, my client will not change, but the web number will, because each website has its own web#.



Well go on and check if that is writeable by your web server user, and make it writeable if it isn’t. If you need help share the

ls -al 

of that directory.


It seems writable:

116 drwxrwxrwx 4 web5 client2 118784 Jun 13 08:10 tmp

Is it good for the permissions to be 777?


No, it’s not good to make it 777, there’s a danger of session hijacking.

You don’t need 777 if the ownerships match your web server user.

You do need the sticky bit on so that new files get the full permissions from their parent directory.

I need to know the user your web server runs under. Can you load this php file from your browser please:

echo exec('whoami');

And then when you have that user name (let’s suppose it’s web5), run this on Linux command prompt to find out which groups it belongs to:

groups web5


The reply that I got was:

Then with the groups command, I get:
web5 : client2 sshusers



Ok Iyou can try to make that writeable via the group permission, so it works for all users inside the client2 group.

So you could try (but do this at your own risk, you’re the one responsible for your server)

sudo chown -R web5:client2 /var/www/clients/client2/web5/tmp


sudo chmod 2770 /var/www/clients/client2/web5/tmp
sudo chmod -R 770 /var/www/clients/client2/web5/tmp/*

This way every user in group client2 should be able to write there, and create new writeable files under that folder. And “world” users get no access at all.


I see you rreply. The only questi nthat I have is that you have:
sudo chown -R web5:client2 /var/www/clients/client2/web5/tmp

This command will work for my client2, yes. But, only for website 5? What about the other websites? web2, or web 13 for example?

When I go to install a CRM under another website, , it will be web13, for example Will the rules apply?

IN other words, if I apply this, will I break the permission issues for the other CRMs I have under other websites?



ps. as for possible messing things up, I planning on backing up the clients folders to preserve permissions. I will tar them.

Yes, despite the ownership being web5, my plan is for every site to work because they will be granted group access, not user access. So if they all belong to the correct group (client2), that should work.

If your system accepts chown client2:client2, that would be fine also. But I don’t know if Linux accepts a group name for a user.

When you specify permissions like 750, the first number rules user access, the second number rules group access, the third rules world access (everyone).

So in my proposal for 770 I was intending for that second 7 to take effect for every webX that is part of group client2, giving write access.

I have been using my CRM for awhile not since trying to fix my problem of gettign kicked out.

I hav found:

I use Ubuntu and Windows and Mac.
Firefox on all of them.
It works on all computers excpt my Ubuntu, unless I use Chrome, then it works

I would like to say that is is a Ubuntu issue - but CRM works under Chrome
I woud llike to say that it is my server - but it works for all my computers, and a friends, except on my Ubuntu using FoireFox
I would like to say FireFox, but all computers (apart from my Mac which is older, all run the current version of Firefox - can not be fire fox

Usign logic, it is a fluke.

But, there is a problem, but not for all computers, only a 1 set up.



Hi, my version is SuiteCRM 7.11.15.
Firstly , I installed CRM with empty data to use. then i need demo data to understand and operate the system.
so I created one CRM with demo data . all is ok. when I log in it happend to me the the same error.
after serveral try, I resolved it on my own server. Here is for your reference.

  1. create new session folder for new CRM demo
  2. grant write perssion for apache user.
  3. specify the session folder in config.php file.
    after above, log in again, the system would create many files in session folder.

I hope it works for you.
mail: hndtraveller@gmail.com

1 Like

Perfect - this solved the problems I was encountering with Apple’s Private Relay feature which was constantly causing sessions to terminate as it cycled IP addresses.