wysiwyg field to layout in PDF Templates


I have a WYSIWYG plugin to add this type of field to studio - works nicely to give me an editor for a Text Area field.

Challenge is that when i insert this type of field into a PDF template - the html does not render into the resulting PDF - the html code is populated into the designated area of the template.

I am using this for the Quotes module - and have my quoting system working very nicely but where I need html rich content - i need to merge a word-type doc generated PDF with the SuiteCRM pdf template output – to get my final doc.

This will probably require some code modifications to get working but without knowing more about your plugin its hard to give you an answer here.

Hello Andy,

Thanks for your reply.

the plugin is in your extensions directory - it is the WYSIWYG field plugin


when i insert this field into a module (quotes in my case) – the field provides the WYSIWYG editor in the field - but when i add this field to the PDF template - it does not render the HTML - rather it insert the raw html.

thanks for reviewing my request.

Hello Andy I have the same issue, on the field everything looks great, but when parsing the variable on to the pdf form editor it renders all the html code, not giving any html format

I have the same problem, i want that the pdf form renders this html field formatted and not the html tags

This is actually a SuiteCRM bug - my developer fixed it - please ping me for a solution - we are getting this fix sent to the SuiteCRM team to address in future releases.

Michael Loveless
vp, operations

Vancouver, BC Canada
Skype: mjel1970
cell: +1-604-679-9329

I could really use said solution, but I’m not sure how to ping you (I can’t seem to find a direct message option in the forums). What’s the best way to get in touch with you directly?

Resolution is here, thanks to Michael:


Doesn’t work for me. I’ve added the lines of code but here’s no change in pdf template, still displays html code.

it has been some time since we had this issue and fixed it -

did you ‘repair’ > quick repair

clear you cache?

let me know if that doesn’t clear the issue I will look further for assistance.

Yes, we’ve done repair and cleared cache, also tried different browsers, no effect. Maybe I didn’t do it properly in the code 'cause I’m no programer (in the editor there were no detected errors in the code)? May the problem depend on the server where the SuiteCRM is installed?