Wrong Password after upgraded to version 7.9.8

all users and admin password passwords become wrong after upgrading to 7.9.8, anyone encountert this issue too?

Yes, same issue with 7.8.9 LTS. Wrong password or sessions expired.
Anyone ?

There’s an open issue here


but the developers can’t reproduce the issue on their own test servers. So if you can go there and add your info that might help.

@uvainternational I saw the error you posted on the Github issue, and I want to ask you about it. But I didn’t want ot complicate that issue there, so I came back here :slight_smile:

Those two messages regarding “exec” and “posix_getpwuid” mean that your hosting is hyper-restrictive, and is not letting SuiteCRM determine which Linux user it’s running under. This is not necessarily a problem, but I’d like to check.

This affects the value that you will find in config.php, item cron, allowed_cron_users. What username(s) do you see inside that? Does that include the user name that your Web server is using to run?

Are your Cron jobs running properly? How exactly did you set them up?

This is worth checking because if your cron jobs are running under the wrong user, they can create permissions problems, and that creates random problems across the app.

@pgr, yes, we use the web server username as follow in the config.php and we are using a 3rd party cron site to run the cron job and it is okay when we test but somehow we see some errors as mentioned.

'allowed_cron_users' => 
array (
  0 => 'ultrav',
  1 => "",

Ok, if you’re using an external service then that is coming in through the Web PHP, not the CLI, so you should be ok with permissions.

That error you’re getting is just SuiteCRM having trouble doing an automatic configuration for you; but you have it correctly configured manually, so don’t worry.

Thanks. Good luck with the other nasty password issue…

But we are still having the issue as follow, is there anything we can do about it?

Warning: exec() has been disabled for security reasons in /home/ultrav/public_html/uva.my/crm/include/utils.php on line 413

Warning: posix_getpwuid() has been disabled for security reasons in /home/ultrav/public_html/uva.my/crm/include/utils.php on line 420

Warning: A non-numeric value encountered in /home/ultrav/public_html/uva.my/crm/modules/Schedulers/Scheduler.php on line 409

Warning: A non-numeric value encountered in /home/ultrav/public_html/uva.my/crm/modules/Schedulers/Scheduler.php on line 412

I noticed that most of the authentication problems in version 7.8.9 are related to extra modules like the SuitePlmproved theme.
In this case the names changes in the fields (https://github.com/salesagility/SuiteCRM/commit/98fac2f403605c1f02071be3b7fc1a42fdb2d3ed):
user_password => username_password

Just go back.

What a mess! It’s username_password in SuiteP theme and user_password in all other themes. Here’s a workaround that checks for both style password names

In modules/Users/Authenticate.php around line 54

$password = isset($_REQUEST['username_password'])
	? $_REQUEST['username_password'] : '';
if ($password=='') 
	$password = isset($_REQUEST['user_password'])
	? $_REQUEST['user_password'] : '';