writing reports

I’m a bit lost here, I’m sure there’s a simple answer.

Trying to write a report in suitecrm 7.2.2.

I can create a new report, add fields but don’t seem to be able to add a condition or chart. I have a list of the fields to the left, added fields on the right, below the added fields is a section headed Conditions but there is no button to add a condition or anyway to click into it to add a condition. I’ve looked over the entire page and can’t find anything. Beneath is a section titled Charts with a button add Chart, clicking this button does nothing.

I’ve found some user guides for sugarcrm which don’t resemble what I’m seeing on screen at all, these guides show options for report types, with next buttons, the whole setup looks very different.

Am I missing some kind of plugin or just missing the plot entirely?

Using accounts I can get an entire list of accounts, when I save the report and view it I have the following error at the top of the report -
Warning: Invalid argument supplied for foreach() in /var/www/vhosts/…/httpdocs/SuiteCRM/modules/AOR_Reports/aor_utils.php on line 68, not sure if this has anything to do with what’s going on here but is the only error that comes up.

screenshot of what I see on screen when writing a report attached.



Conditions are added in the same way as fields - fields are dragged across to the condition panel and then setup from there.

The warning you are seeing should be disabled. You can turn this off by setting display_errors to Off in your php.ini file.

Not sure why the charts button isn’t working but it’s likely related to display_errors being on.


thank you so much, conditions - so simple! Thank you :slight_smile:

I don’t seem to be able to find the php.ini file in the suitecrm install so I expect this will be the servers php file? I can request my host to fix this, do you know if changing this setting is likely to upset my wordpress site which is installed into the same htdocs directory on that server?


Yeah, this is a server setting, where the php.ini file is will depend on the server. It shouldn’t affect your wordpress install, however if you are worried it’s also possible to change this setting using a .htaccess file (depending on your host). Information on doing this can be found here: http://php.net/manual/en/configuration.changes.php


judging from the image you attached I believe that you also have some permissions problems (normally wrong permissions are the cause of the “undefined” labels being displayed instead of the correct ones).

You can search the forum for literally hundreds of posts telling you how to set up conditions correctly. In one of my previous posts I also attached a script for linux to set them correctly (but the script is not sufficient because you have to modify config.php also)

Had a go at changing the permissions, I was tricked by the message that I had correct permissions on install!! I can now include a chart and I have options on the Edit button to export etc.

@Jim - I’m still waiting to hear from hosting about changing the php.ini file as the error message is still there post changing permissions.

Thanks for your help amariussi (again!)


Jim, host wasn’t able to change the php.ini file but suggested changes to the .htaccess file, which didn’t work. I found a post at stackoverflow that referred to shared hosting and not being able to disable display_errors by modifying the .htaccess file and using the index.php file instead.

So, I’ve added

<?php ini_set('display_errors','off'); ?>

to the beginning of the index.php in the suitecrm directory and the error has gone. Not sure if this will affect anything else though.

Thanks for your help :slight_smile: