Workflow not updating a field in a custom module

I am using suiteCRM Version 7.12.5
I created a custom module and I am using it with a workflow, the module has a checkbox field (boolean) that the workflow has to update once it has run. the workflow must send an email and then set the check field so that next time that record does not meet the conditions and therefore the email is sent only once.
The workflow is executed because the email is sent, but for some reason it is not updating the field.
these are the conditions that are set in the workflow for the actions to execute:


Ant this are the actions that are to be executed by the workflow:

The strange thing is that the email is sent but the SOLICITUD does not get the values updated.

Any suggestions on what could be the issue here?

Try filling that dropdown to the right of “Now”.

Check your logs for errors.

The dropbox to the right of now is already filled with the minus 5 minutes from now.
In fact those conditions are workign fine because the email is sent.
The problem is with the action of modifying the SOLICITUD fields which does not work. I already checked the suitecrm.log for errors but I am unable to find or interpret a clear reason for this not working…

Unless you are refering to the Now by the last auto reminder field with I have now tried to fill with a minus 0 minutes value… lets see if that changes anything.

I have tried even redoing the whole workflow, but it still wont update the field.

I don’t know, there could be some bug there…

I would just try different things to attempt to get more focus of where the problem can be.

Try updating just one field. Try updating a different kind of field. Try updating without sending a mail first.

Aparently it must have something to do with the sending of the email. If I remove the email send task from the workflow, the fields get updated correctly.
Also I noticed that if I look the workflow log, if I remove the action that sends the email, then when the tasks ends appears as completed, while otherwise is just stays as running.

I finally got it to wirk, but there must be some bug in the workflow code. This is what I have done or figured out so far:

  1. First I was able to have the workflow modify the custom module fields by simply removing the action that sent the email. One other thing I noticed is that after removing the email sending action, in the workflow audit, the task apeared as completed while before it would appear as running.
  2. Next I added again a task to send the email where I sent the email both to the contact email address associated to that request and a CC to my email. After doing that, I faced the same problem and the custom module fields were not updated (and the workflow audit displayed the task as running instead of completed).
  3. Finally I simply removed the CC to my email from the email sned action and it all seemed to work correctly although the audit still shows the task as running instead of completed.

Any thoughts?

to

Usually there is a clue in your error log why the workflow crashes out. That would help you determine why it’s behaving like that.

Consider 2 separate workflows. If both work separately, don’t combine them into one WF. Or, consider changing the order, do the update first and the email second would be the first couple of things I’d try.

I already tried changing the order of the actions but the only thing that seems to be making the workflow fail is when I add a send email action and in the same email action I add a second CC address … then the email to the to: address is sent but not the CC: and the other action to update the variables fails.

I have not tried yet to send the second mail in a separate email action, but will try soon

Actually, now it seems to be working ok even with the sending of the CC address …
I gues that with all the process of testing something must have gotten fixed.

Any clues what may have got it working again for you?