Workflow for date not working

:frowning: anyone please help me
Workfow for privous date not working.


Could you give us more information? What about this isn’t working?
From the screenshots it looks as though the workflow is firing as expected.

thanks for reply sir, its working correct from current date , but not working from previous date.

screenshot 1: I add date 1/1/2015 and save

Screenshot 2 : In detail view Valid until shows Wrong date.

Screenshot 3: edit form again

screenshot 4: Save Then its indicate right date in detail view

For 1 form i have to save twice .

This seems like an issue.
I have logged it on our Github here: #533

However, to help minimize the issue, we can set up your Scheduled Tasks.

Go to Admin > Schedulers and select “Process Workflow Tasks”
What is the “Last Successful Run” and is there any data under “Job Log”?

1 Like

Thanks for issue logged on github,
I check Admin > Schedulers >“Process Workflow Tasks” screenshot are following.
Please update me.

Your scheduled Tasks are not set up,

Go to Admin > Schedulers
and at the bottom of the page you will see a line in bold. I have attached an example of this line, the line that you see may be different. Copy this line.

If your SuiteCRM is hosted on a Linux instance:
Paste the line mentioned above into the bottom of your Crontab file and save the file.

If it is on a Windows Instance, you can follow the guide on the SugarCRM support page:

Afterwards, go to Admin > Repair and run a Quick Repair & Rebuild.

1 Like

Hii sir ,
I set the cron job but its not working. i attached my current
Process Workflow Tasks


For this to work, you will need to enable “Repeated Runs” on your Workflow and set it to run on “All Records”

Take note that this means it will Check if any of your calls match the Workflow Conditions on a regular basis. This could put some load on your server.

Sir can u suggest any other way to auto calculate date in suitecrm

Hii sir my Repeated Runs is enable and it’s run on all recod having same problem

It should now update any records that have “Duration” set to “6 Months” automatically.
The workflow may take a few minutes to fire and set the Dates correctly. You will also have to refresh the page to see the results.

If it is still not working, Is there any data in the Workflow’s “Process Audit” subpanel?
and, Are there any records that actually meet your Workflow’s Conditions?

1 Like

Hii sir , It seem to problem is solved.

I Replacece line 197 in modules/AOW_Actions/actions/actionCreateRecord.php ( $date = $bean->fetched_row[$params[‘value’][$key][0]]; )

With $date = $bean->$params[‘value’][$key][0]; and currently its working fine.

I find This from Here

Good to hear its working!
Thanks for the link to the solution. This could help someone else that finds this thread with the same issue.

Thank you,

The problem is still there in version 7.4.3

$date = $bean->$params[‘value’][$key][0];

worked for me too.