📣 We're Hiring!

workflow bug

Hi I have find a bug in my crm, when i create a workflow and in the actions section I select “Send Email” but the related fileds “email”, “Email template”… don’t appear.
I tried with the demo version and section actions works

:blink:

Tell us your SuiteCRM version (always!) and please check your logs for errors at the time you open that option

suitecrm.log
php_errors.log

It might be a good idea to also check for javascript errors in Browser’s Developer Console.

Hi,
I have the version 7.10.4.

php_errors.log doesn’t exist, I tried to find the file in all my debian system.

In the file suitecrm.log there is the error: “SugarBean::populateDefaultValues $field_defs should be an array” but I don’t think it is linked

I have attached a screenshot about the javascript errors in Browser’s Developer Console and there aren’t errors

Go find your Apache log, it’s important:

https://unix.stackexchange.com/questions/115972/how-do-i-find-where-apache-keeps-the-log-files

let’s hope there are more clues there.

Thanks, I have fixed the problem. :wink:
I had created a custom module and then I deleted it but there were some traces that created problems. I deleted these traces and now it works.

However, this error remains in the file suitecrm.log : “SugarBean::populateDefaultValues $field_defs should be an array”
Any ideas about that?

Still, follow my advice, please go and find your Apache log. You’re much better off paying attention to that log.

About the suitecrm.log message, if it’s not ERROR or FATAL, and you don’t see symptoms of any broken functionality, I’d say it’s safe to ignore.

I’m glad you were able to solve your problem.

I solved the problem by looking at the errors in my Apache log.
While The error in Suitecrm.log is FATAL :ohmy:

That error started coming up a lot about 2 or 3 months ago. Then in 7.10.4 we improved it, see

https://github.com/salesagility/SuiteCRM/issues/5239

but I still don’t know for sure if that is a real problem. I’d like to understand if it actually breaks something or not.