Windows IIS installation

Where should I put php files?

Wherever your IIS will serve them. This is usually called a wwwroot or a docroot, but that is a matter of IIS configuration. It has a default value (I don’t know what it is), and of course you can configure it to serve from other directories as well.

C:\inetpub\wwwroot\ ?

Probably. But sort of thing, there’s no point in asking, it’s better to just try it :wink:

Can’t remove read-only from C:\inetpub\wwwroot\SuiteCRM

The Custom Directory exists but is not writeable. You may have to change permissions on it (chmod 766) or right click on it and uncheck the read only option, depending on your Operating System. Please take the needed steps to make the file writeable.

You’re asking a Windows question… there are plenty of sites out there explaining how to set permissions on Windows.

For example (just an example!), on an elevated (Administrator) Command prompt, this:

icacls c:\inetpub\wwwroot\ /grant "IIS AppPool\DefaultAppPool:F"

If the user name that IIS is using in your system is “IIS AppPool\DefaultAppPool”, then this will give it full access. Note that this is not secure, it means “open wide” permissions. You can use it to test. Then make sure you set something tighter.

This is also achievable form the UI, I just find it’s often faster and simpler to run the command-line command.

This is IIS issue, not Windows. I give full control to BUILTIN\IIS_IUSRS and uncheck ‘read-only’ on directory, but somehow it became immediately read-only again.
(Get-Acl -Path C:\inetpub\wwwroot\SuiteCRM).Access
FileSystemRights : FullControl
AccessControlType : Allow
IdentityReference : BUILTIN\IIS_IUSRS
IsInherited : False
InheritanceFlags : ContainerInherit, ObjectInherit
PropagationFlags : None

FileSystemRights : ReadAndExecute, Synchronize
AccessControlType : Allow
IdentityReference : BUILTIN\IIS_IUSRS
IsInherited : True
InheritanceFlags : None
PropagationFlags : None

Check the link below. It’s for SugarCRM but most of it is still valid for SuiteCRM:


Still the same error.

icacls c:\inetpub\wwwroot\SuiteCRM\ /t /grant “NT AUTHORITY\IUSR:F”

It works now. We have user group ‘BUILTIN\IIS_IUSRS’ and user ‘NT AUTHORITY\IUSR’
Usually we gave permission on group level, not user level. In my case I must gave permission to group and user.

also i change php.ini
cgi.force_redirect = 0

fastcgi.impersonate = 1